Bug 680766 - [abrt] mdds::flat_segment_tree<int, unsigned short>::search_tree
Summary: [abrt] mdds::flat_segment_tree<int, unsigned short>::search_tree
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mdds
Version: 14
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Tardon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6652b099640b54228be44a9d1b1...
: 695660 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-27 16:20 UTC by A. Lok
Modified: 2011-04-12 11:03 UTC (History)
3 users (show)

Fixed In Version: libreoffice-3.3.2.2-5.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-29 03:53:21 UTC


Attachments (Terms of Use)
File: backtrace (64.79 KB, text/plain)
2011-02-27 16:20 UTC, A. Lok
no flags Details

Description A. Lok 2011-02-27 16:20:51 UTC
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 66346 bytes
cmdline: /usr/lib64/openoffice.org3/program/swriter.bin -writer file:///tmp/kerkblad%202902%20W03.doc
component: openoffice.org
Attached file: coredump, 153907200 bytes
crash_function: mdds::flat_segment_tree<int, unsigned short>::search_tree
executable: /usr/lib64/openoffice.org3/program/swriter.bin
kernel: 2.6.35.11-83.fc14.x86_64
package: openoffice.org-writer-1:3.3.0-20.2.fc14
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/swriter.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1298821060
uid: 500

How to reproduce
-----
1. Had an MS Word-document with an table in it.
2. Copied the table bij selecting all cells with the mouse and CTRL-C
3. Paste the table in Calc
4. Removed some rows, changed the format of some cells.
5. Removed the first column.
6. Crash!

I was able to reproduce it once, but it seems I can't reproduce it anymore.

Comment 1 A. Lok 2011-02-27 16:20:55 UTC
Created attachment 481255 [details]
File: backtrace

Comment 2 David Tardon 2011-02-28 09:41:03 UTC
This looks like a bug in mdds. Let's see if its maintainer agrees :)

Comment 3 David Tardon 2011-03-24 14:58:14 UTC
Committed probable fix to mdds (together with a couple of other fixes). It will still be necessary to update openoffice.org after the new mdds package gets into updates.

Comment 4 Fedora Update System 2011-03-24 15:01:42 UTC
mdds-0.3.0-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mdds-0.3.0-3.fc14

Comment 5 Fedora Update System 2011-03-24 15:21:25 UTC
mdds-0.5.1-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mdds-0.5.1-3.fc15

Comment 6 Fedora Update System 2011-03-29 03:53:16 UTC
mdds-0.5.1-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2011-03-30 19:02:57 UTC
libreoffice-3.3.2.2-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libreoffice-3.3.2.2-4.fc15

Comment 8 Fedora Update System 2011-03-31 15:31:11 UTC
libreoffice-3.3.2.2-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libreoffice-3.3.2.2-5.fc15

Comment 9 Fedora Update System 2011-04-01 18:29:03 UTC
mdds-0.3.0-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-04-05 21:41:32 UTC
libreoffice-3.3.2.2-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Caolan McNamara 2011-04-12 11:03:24 UTC
*** Bug 695660 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.