Bug 680779 - Can't use the panel's tabs to switch windows
Summary: Can't use the panel's tabs to switch windows
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-panel
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-27 17:34 UTC by Horst H. von Brand
Modified: 2011-03-28 06:13 UTC (History)
3 users (show)

Fixed In Version: xfce4-panel-4.8.2-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-28 06:13:11 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Xfce 7362 0 None None None Never

Description Horst H. von Brand 2011-02-27 17:34:22 UTC
Description of problem:
I've got firefox (full screen) and two Terminals open right now. Clicking on the respective tabs on the panel doesn't switch (foreground) the repective window anymore.

Version-Release number of selected component (if applicable):
xfce4-panel-4.8.2-1.fc16.x86_64
xfce4-mixer-4.8.0-1.fc16.x86_64

How reproducible:
Allways (I think)

Steps to Reproduce:
1. Open several windows
2. Click on tabs on the panel
3.
  
Actual results:
Nothing

Expected results:
Switch/foregrund the window on whose tab you clicked

Additional info:

Comment 1 Kevin Fenzi 2011-02-27 18:47:28 UTC
What settings do you have in:

prefs->window manager->focus
and
prefs->window manager tweaks ->focus

Comment 2 Christoph Wickert 2011-02-27 19:04:29 UTC
(In reply to comment #0)
> Description of problem:
> I've got firefox (full screen)

Which fullscreen mode? The one from firefox or from xfwm4?

And how can you click on the panel, if firefox is in fullscreen mode?

Comment 3 Horst H. von Brand 2011-02-27 19:07:26 UTC
(In reply to comment #1)
> What settings do you have in:
> 
> prefs->window manager->focus
> and
> prefs->window manager tweaks ->focus

Havent' changed anything in a long time:

Focus: Click to focus; New window focus; Raise on click

No "Windows manager tweaks" around here.

BTW, the Preferences -> Windows Manager window does react normally (?!)

Comment 4 Horst H. von Brand 2011-02-27 19:09:26 UTC
(In reply to comment #2)
> (In reply to comment #0)
> > Description of problem:
> > I've got firefox (full screen)
> 
> Which fullscreen mode? The one from firefox or from xfwm4?

Firefox opens fullscreen

> And how can you click on the panel, if firefox is in fullscreen mode?

Maybe the name is wrong... I mean the upper bar.

Comment 5 Horst H. von Brand 2011-02-27 22:07:19 UTC
Just found out that if there are two windows under a tab that one doesn't work. I.e., just now I have (Boxed shows the pressed button):

+---------+
| Firefox | Terminal (2) | Xemacs |
+---------+

Pressing the Terminal button opens the menu for both Terminal windows,pressing either has no effect. Pressing the Xemacs button puts the Xemacs window in the foreground (but the buttons' appearance doesn't change), now pressing Firefox gets that one in the foreground (no change in appearance again).

Comment 6 Horst H. von Brand 2011-02-27 22:38:08 UTC
(In reply to comment #5)
> Just found out that if there are two windows under a tab that one doesn't work.
> I.e., just now I have (Boxed shows the pressed button):
> 
> +---------+
> | Firefox | Terminal (2) | Xemacs |
> +---------+
> 
> Pressing the Terminal button opens the menu for both Terminal windows,pressing
> either has no effect. Pressing the Xemacs button puts the Xemacs window in the
> foreground (but the buttons' appearance doesn't change), now pressing Firefox
> gets that one in the foreground (no change in appearance again).

Closing one of the two Terminals makes the buttons behave normally

[I'm using this XFCE configuration from way back, this is probably not the default.]

Comment 7 Kevin Fenzi 2011-03-08 01:09:20 UTC
Odd. I can't duplicate this here. 

Is it only terminals that do it? Or anything with multiple windows? 

This is rawhide? Or f15 branched?

Comment 8 Horst H. von Brand 2011-03-08 18:10:05 UTC
This is rawhide (16).

It seems to happen each time I've got several windows with the same title.

Comment 9 Horst H. von Brand 2011-03-09 02:41:07 UTC
Just checked again: Now the appearance of the buttons change when I switch applications, but if I have e.g. 2 Terminals, I can't switch to either. If I close one of them (via the dropdown menu for that window), all returns to normal.

Comment 10 Horst H. von Brand 2011-03-10 16:13:14 UTC
Just confirmed that having two xpdf or two eog open doesn't allow to switch to either of the pair, others work fine.

Comment 11 Christoph Wickert 2011-03-12 22:17:49 UTC
This sounds like http://bugzilla.xfce.org/show_bug.cgi?id=7383

Comment 12 Horst H. von Brand 2011-03-16 15:00:42 UTC
Now xfce4-panel-4.8.2-2.fc15.x86_64 (rawhide ~~-> 15), same as before.

Comment 13 Raphael Groner 2011-03-25 18:31:38 UTC
Upstream says that it has been fixed since end of February 2011.

http://bugzilla.xfce.org/show_bug.cgi?id=7362

Comment 14 Fedora Update System 2011-03-25 19:46:33 UTC
xfce4-panel-4.8.2-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xfce4-panel-4.8.2-3.fc15

Comment 15 Fedora Update System 2011-03-26 04:50:47 UTC
Package xfce4-panel-4.8.2-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce4-panel-4.8.2-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xfce4-panel-4.8.2-3.fc15
then log in and leave karma (feedback).

Comment 16 Horst H. von Brand 2011-03-28 01:57:24 UTC
Fixed in xfce4-panel-4.8.2-3.fc15.x86_64 (sorry, hadn't checked before)

Comment 17 Fedora Update System 2011-03-28 06:13:06 UTC
xfce4-panel-4.8.2-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.