Bug 680821 - Cannot start virtual machine on amd64
Cannot start virtual machine on amd64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-27 18:06 EST by Krzysztof Urbaniak
Modified: 2013-01-09 06:48 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-26 10:19:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Loaded modules (2.57 KB, text/plain)
2011-03-11 11:29 EST, Krzysztof Urbaniak
no flags Details
kernel log (63.36 KB, text/plain)
2011-03-11 11:30 EST, Krzysztof Urbaniak
no flags Details

  None (edit)
Description Krzysztof Urbaniak 2011-02-27 18:06:56 EST
Description of problem:
When trying to start (even created on f14, before upgrade) or create any virtual machine on f15 I've got:
Error starting domain: internal error process exited while connecting to monitor: kvm_create_vm: Device or resource busy
failed to initialize KVM: Operation not permitted


Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/engine.py", line 956, in asyncfunc
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 1048, in startup
    self._backend.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 330, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error process exited while connecting to monitor: kvm_create_vm: Device or resource busy
failed to initialize KVM: Operation not permitted

kernel log (dmesg) says:
[  270.378875] kvm: enabling virtualization on CPU0 failed
[  270.484646] kvm: enabling virtualization on CPU0 failed

I've double checked that virtualization is enabled in bios, it just worked some time ago

Version-Release number of selected component (if applicable):
urban@athlon> uname -a
Linux athlon 2.6.38-0.rc6.git4.1.fc15.x86_64 #1 SMP Fri Feb 25 03:46:42 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

urban@athlon> rpm -qa|egrep '(qemu|libvirt)'
qemu-system-x86-0.14.0-0.1.201102107aa8c46.fc15.x86_64
libvirt-0.8.8-2.fc15.x86_64
libvirt-client-0.8.8-2.fc15.x86_64
qemu-common-0.14.0-0.1.201102107aa8c46.fc15.x86_64
gpxe-roms-qemu-1.0.1-4.fc15.noarch
libvirt-python-0.8.8-2.fc15.x86_64
qemu-img-0.14.0-0.1.201102107aa8c46.fc15.x86_64
urban@athlon>      

Steps to Reproduce:
1. Try to start/create virtual machine on f15 by ie. virt-manager



Additional info:

processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 16
model		: 2
model name	: AMD Athlon(tm) 7750 Dual-Core Processor
stepping	: 3
cpu MHz		: 1350.000
cache size	: 512 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 5
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs npt lbrv svm_lock
bogomips	: 5424.54
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate

and second, the same core
Comment 1 Krzysztof Urbaniak 2011-02-27 18:08:52 EST
The same kernel and so on, on intel core2duo processor works fine, so this bug is related only to kvm_amd.
Comment 2 Justin M. Forbes 2011-03-07 15:43:07 EST
Reassiging to kernel since this is a kernel kvm issue, not qemu.  The kvm-amd module is failing to load correctly.
Comment 3 Chuck Ebbert 2011-03-08 02:32:09 EST
Please run the dmesg command and post the output as a plain text attachment after booting the system and attempting to run a virtual machine.
Comment 4 Avi Kivity 2011-03-08 06:36:37 EST
Do you have virtualbox or vmware running in parallel?
Comment 5 Krzysztof Urbaniak 2011-03-11 11:29:27 EST
Created attachment 483768 [details]
Loaded modules
Comment 6 Krzysztof Urbaniak 2011-03-11 11:30:49 EST
Created attachment 483769 [details]
kernel log

Added output of dmesg and lsmod after trying to start virtual machine.
I dont have any other virtualization software installed.
Comment 7 Chuck Ebbert 2011-03-11 18:56:44 EST
First it says virt is enabled, then later it says it can't enable it??

[   17.443455] kvm: Nested Virtualization enabled
[   17.443460] kvm: Nested Paging enabled

[ 3823.798210] kvm: enabling virtualization on CPU0 failed
[ 3823.942960] kvm: enabling virtualization on CPU0 failed
Comment 8 Amit Shah 2011-03-11 23:21:33 EST
Please answer the question in comment 4.  Also, check if there's a BIOS update available (and apply it if available).
Comment 9 Krzysztof Urbaniak 2011-03-12 03:26:45 EST
Ad I say in comment 6, I dont have any other virtualization software installed.
I am using the latest bios for GA-MA770-UD3, and virtualization has worked before upgrading to f15.
Comment 10 Josh Boyer 2011-09-26 10:01:59 EDT
Does this still happen with the 2.6.40.x kernel updates?
Comment 11 Krzysztof Urbaniak 2011-09-26 10:10:47 EDT
I've tried it on: 2.6.40.3-0.fc15.x86_64 and it works fine, should be closed now.
Comment 12 Josh Boyer 2011-09-26 10:19:31 EDT
(In reply to comment #11)
> I've tried it on: 2.6.40.3-0.fc15.x86_64 and it works fine, should be closed
> now.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.