Bug 68086 - Can't use Japanese words at Google-search with Konqueror
Summary: Can't use Japanese words at Google-search with Konqueror
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kdenetwork   
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-06 06:44 UTC by Need Real Name
Modified: 2007-04-18 16:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-01 00:29:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-07-06 06:44:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020625

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Go to "www.google.co.jp" with Konqueror.
2.Enter some japanese words and click search-button.

	

Actual Results:  There are no results.

Expected Results:  some results.

Additional info:

Galeon is OK.

Comment 1 Warren Togami 2002-07-10 12:26:38 UTC
Is this behavior anything like what is reported in Bug 62445?

Comment 2 Need Real Name 2002-07-10 17:27:13 UTC
>Is this behavior anything like what is reported in Bug 62445? 
>>kinput2 status window doesn't show, but input and alternate selection works.
If you say "..and I could get the google-search-results",the answer is NO.

In Limbo,you'll see "kinput2 status window doesn't show, but input and 
alternate selection works" again,but it's not so important.
The problem is "You can't get the google-results".
Look at these pictures:
1.Japanese words in google-search-box
(h)ttp://www.geocities.jp/knee2525/google01.png
2.the result
(h)ttp://www.geocities.jp/knee2525/google02.png
You can't go directly,so please delete "()" and paste the addresses.

Comment 3 Warren Togami 2002-07-15 11:34:34 UTC
It appears that this bug is not Bug 62445, but a regression that behaves like
Bug 62446.  Japanese entered text in Konqueror does not submit to the Google
search.  However, Japanese pasted characters does submit, and so does a mixture
of Japanese and English characters.

Comment 4 Warren Togami 2002-07-24 08:17:18 UTC
It appears that Konqueror is submitting the form improperly in certain
circumstances.  You can see this behavior by submitting Japanese text
immediately after it is written with kinput2.  Watch the text within the URL
bar.  Then try it after you cut & paste Japanese text into the Google search
textbox or mix Japanese and English characters.  The search text shows up
incorrectly before the encoding in the former case, but properly after encoding
in the latter.


Comment 5 Need Real Name 2002-07-24 09:23:42 UTC
This bug will be fixed if you use qt-3.0.5.
I use latest Mandrake-Cooker now, and
I can search correctly with google search.
A few days ago (it used qt-3.0.4), I couldn't do it.   

Also see http://www.kde.gr.jp/patch/
Japanese KDE users report about bugs in qt-3.0.3.




Comment 6 Leon Ho 2002-08-01 00:29:06 UTC
Fixed in rawhide.

Comment 7 Jay Turner 2002-08-21 20:14:34 UTC
Fix confirmed with qt-3.0.5-13.


Note You need to log in before you can comment on or make changes to this bug.