Bug 68087 - Default font hinting system makes kwin menu unreadable
Summary: Default font hinting system makes kwin menu unreadable
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-06 06:48 UTC by Mike MacCana
Modified: 2007-04-18 16:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 11:36:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike MacCana 2002-07-06 06:48:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
Freetype's default font hinting algorithm is quite poor. When combined with the font used on KDE window titles, the titles become unreadable.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run KDE on Red Hat Limbo
2.Choose the default settings
3.Try and read the title on any window
	

Actual Results:  The letters are unreadable - eg, an `e' becomes a blotchy ball with no cavity in the middle of the character.

Expected Results:  Fonts were readable.

Additional info:

The problem can easily be resolved in two ways:
1. Although the superior Freetype hinting algorithm is patented by apple, and therefore unavaliable for use by Red Hat, the `XFT Hack' `half-hinting' patch at http://www.cs.mcgill.ca/~dchest/xfthack/ would fix this situation and vastly improve the font rendering on QT and GTK apps alike in Limbo.
2. Disable the current hinting / antialiasing so that text is readable by default.

Comment 1 Mike A. Harris 2002-07-10 00:58:55 UTC
Yes, these ugly fonts are due to the fact that the bytecode interpreter is
disabled in freetype.  I've discussed this with Keith Packard in the past
as well.  I'm not willing to hack up Xft or freetype unless the upstream
maintainers of these libraries buy-in to the patches themselves and include
the functionality directly into freetype or Xft.  Otherwise then we must
maintain our own freetype and/or Xft that is different from everyone
elses.

The solution is to recompile freetype with the bytecode interpreter enabled
to get real font hinting - which I've conveniently made a spec file define
to make it easier for people to enable the code.

Owen, Havoc - any comments you'd like to add before I close the bug?


Comment 2 Owen Taylor 2002-07-10 03:43:45 UTC
The problem is misconfiguraiton of KDE, and possibly also fontconfig
picking up the TrueType versions of the Luxi fonts rather than the
Type1 version. (I need to look at how to force fontconfig to get
the Type1 versions.)

We have several options for quite readable fonts in GNOME now, and 
we are using the same basic technology in KDE.

Actually, I have no idea why KDE is getting hinting in Limbo -
it should be disabled in /etc/X11/Xresources.

Comment 3 Mattias Dahlberg 2002-07-10 12:16:53 UTC
I've also encountered strange looking fonts in Limbo. Here's a couple of 
screenshots of two different font issues:

http://users.du.se/~mda/konquerorfont.png
(the blue link text looking funny)

http://users.du.se/~mda/konsole.png
(fonts look good, but letters very far apart)


Comment 4 Havoc Pennington 2002-08-22 21:13:46 UTC
Probably a matter of KDE not using "Sans-serif 10" and "Mono 10" as the defaults.

Comment 5 Harald Hoyer 2002-08-23 11:36:52 UTC
fixed in NULL

Comment 6 Jay Turner 2002-08-30 03:03:20 UTC
Fix confirmed with kdebase-3.0.3-7.


Note You need to log in before you can comment on or make changes to this bug.