Bug 680876 - Show Fedora installer somewhere
Show Fedora installer somewhere
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 681045 681079 (view as bug list)
Depends On:
Blocks: F15Blocker/F15FinalBlocker
  Show dependency treegraph
 
Reported: 2011-02-28 04:48 EST by Bastien Nocera
Modified: 2011-04-19 11:28 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-14 15:33:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2011-02-28 04:48:38 EST
In GNOME 3, and because nautilus doesn't manage the desktop any more, the "Install to Hard Disk" option of Anaconda isn't displayed prominently in the interface.

We should show it somewhere, either with the rest of the favourite applications, or within the user menu, next to suspend and log out, when running from a liveCD.
Comment 1 Matthias Clasen 2011-02-28 06:59:01 EST
Favourite sounds good to me.
How does the shell keep its favourites ?
Comment 2 Ray Strode [halfline] 2011-02-28 10:24:00 EST
Note, we're talking about eventually having "Install Updates & Restart" here in the user menu:

https://live.gnome.org/GnomeShell/Design/Whiteboards/SystemStopRestart

So your idea of putting the installer their makes sense, to mee, too. "Install System & Restart" or some such.
Comment 3 Adel Gadllah 2011-02-28 17:31:40 EST
*** Bug 681045 has been marked as a duplicate of this bug. ***
Comment 4 Adam Williamson 2011-02-28 17:40:40 EST
a favourite doesn't sound like a great idea to me, particularly since there's no text on the favourites now; you'd be relying on people figuring out what the icon meant by educated guesswork. Within the user menu sounds like a better bet to me as it'd be text, so it'd be clear what it was. I didn't mind the idea someone mentioned on the list of having a Nautilus window with the icon in it wired into the live desktop somehow; this is how it's handled for KDE 4, FWIW.
Comment 5 Adam Williamson 2011-02-28 17:41:53 EST
the advantage of that approach is that it removes the need for any user activity at all in order to discover the install option (which matches the GNOME 2 situation).
Comment 6 A S Alam 2011-02-28 22:27:05 EST
*** Bug 681079 has been marked as a duplicate of this bug. ***
Comment 7 Brian Lane 2011-03-01 12:05:40 EST
(In reply to comment #5)
> the advantage of that approach is that it removes the need for any user
> activity at all in order to discover the install option (which matches the
> GNOME 2 situation).

I think this is the correct approach. Currently the logic for this lives in zz-liveinst.sh inside anaconda's data/liveinst/ directory. That doesn't really seem like the right place for it to me. It would make more sense to have the spin's %post setup the launcher itself, since the method is tied to the desktop manager being used.
Comment 8 Matthias Clasen 2011-03-04 18:10:50 EST
(In reply to comment #4)
> I didn't mind the idea
> someone mentioned on the list of having a Nautilus window with the icon in it
> wired into the live desktop somehow; this is how it's handled for KDE 4, FWIW.

We don't want to make random changes to the user experience like that. 

IMO, if the main purpose of the live cd is to function as a very obvious installer, we should just run the installer at login. That will be hard to overlook, and if people don't want to install right now, they can just close it.
Comment 9 Matthias Clasen 2011-03-07 18:36:03 EST
The new proposal coming out of the mailing list discussion is to use a persistent notification.
Comment 10 James Laska 2011-04-14 14:30:42 EDT
In the live image, the "Install to hard drive..." .desktop entry exists in the Fallback menus, and has been added as a 'Favorite' in the Shell activities.  Is anything more planned for this bug?
Comment 11 Bruno Wolff III 2011-04-14 15:33:10 EDT
I wanted to ask the Desktop guys why they renamed the desktop file anaconda, as that doesn't seem to be needed, but the solution does work as is. There is an icon and explanatory text so I think we can close this one. (And so I will.)
Comment 12 Elad Alfassa 2011-04-19 11:28:31 EDT
Favorite applications does not have names or descriptions visible, only tooltips for names. Users might not know what the icon means (and IMO we shouldn't relay on tooltips). Persistent notification sounds like a better solution IMO.

Note You need to log in before you can comment on or make changes to this bug.