Bug 680878 - -devel package should require libXtst-devel
Summary: -devel package should require libXtst-devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libfakekey
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-28 10:02 UTC by Daiki Ueno
Modified: 2011-03-23 04:57 UTC (History)
1 user (show)

Fixed In Version: libfakekey-0.1-6.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-22 18:56:17 UTC


Attachments (Terms of Use)

Description Daiki Ueno 2011-02-28 10:02:10 UTC
Description of problem:

If I install libfakekey-devel with yum, try to compile some program using it, and I get the following error:

 /usr/include/fakekey/fakekey.h:13:34: fatal error: X11/extensions/XTest.h: No such file or directory

Version-Release number of selected component (if applicable):
libfakekey-devel-0.1-5.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1. yum erase libXtst-devel
2. yum install libfakekey-devel
3. compile some program using libfakekey
  
Actual results:
Get the compile error as above, because of missing dependency on libXtst-devel.

Expected results:
libXtst-devel should be automatically installed on the step 2.

Additional info:

Comment 1 Fedora Update System 2011-03-14 02:58:18 UTC
libfakekey-0.1-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libfakekey-0.1-6.fc14

Comment 2 Fedora Update System 2011-03-14 02:58:24 UTC
libfakekey-0.1-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libfakekey-0.1-6.fc15

Comment 3 Fedora Update System 2011-03-22 18:56:13 UTC
libfakekey-0.1-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2011-03-23 04:57:27 UTC
libfakekey-0.1-6.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.