Bug 681003 - pungi for rawhide fails: "could not find anaconda lang-table, exiting"
pungi for rawhide fails: "could not find anaconda lang-table, exiting"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-28 13:37 EST by Horst H. von Brand
Modified: 2013-07-04 08:54 EDT (History)
5 users (show)

See Also:
Fixed In Version: lorax-0.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-18 03:36:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logfile with "--ver rawhide" (1.66 MB, text/plain)
2011-03-07 15:39 EST, Horst H. von Brand
no flags Details
With "--ver 15" (2.72 KB, text/plain)
2011-03-07 15:40 EST, Horst H. von Brand
no flags Details
Using "/usr/share/pungi/rawhide-fedora.ks", no --ver (3.57 MB, application/octet-stream)
2011-03-07 15:41 EST, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2011-02-28 13:37:16 EST
Description of problem:
I'm trying to create a rawhide-x86_64 install DVD, using a local mirror. I copied 
/usr/share/spin-kickstarts/fedora-install-fedora.ks to /tmp, changing the repo line and changing the size to DVD. Then I ran:

pungi --force --nosource --nodebuginfo --flavor Fedora --name Fedora --ver rawhide -c /tmp/fedora-install-fedora.ks

After a while the command exits with:

could not find anaconda lang-table, exiting

Version-Release number of selected component (if applicable):
pungi-2.5-2.fc15.noarch

How reproducible:
No idea, I'd assume always

Steps to Reproduce:
1. Run pungi to create rawhide DVD
2.
3.
  
Actual results:


Expected results:
Installation DVD image

Additional info:
Comment 1 Jesse Keating 2011-03-03 17:28:41 EST
THis seems more like a lorax issue.  Reassigning.
Comment 2 Martin Gracik 2011-03-04 02:30:20 EST
This means you don't have anaconda package installed in the installtree. Maybe it's missing from the repo?
Comment 3 Horst H. von Brand 2011-03-04 12:06:21 EST
$ rpm -q pungi anaconda lorax
pungi-2.5-2.fc15.noarch
anaconda-16.1-1.fc16.x86_64
lorax-0.3-3.1.fc16.noarch

All clean (sez "rpm -V")
Comment 4 Horst H. von Brand 2011-03-04 12:07:03 EST
$ locate lang-table
/usr/share/anaconda/lang-table
Comment 5 Horst H. von Brand 2011-03-04 14:15:39 EST
(In reply to comment #2)
> This means you don't have anaconda package installed in the installtree. Maybe
> it's missing from the repo?

Hum... in rawhide/Fedora/x86_64/os/Packages/ under the directory where I ran pungi there is no anaconda package. Is that what you mean?
Comment 6 Chris Lumens 2011-03-04 14:24:30 EST
You definitely need anaconda in one of the repos listed in your kickstart file, as lorax will look for it:

share/ramdisk.ltmpl:## anaconda package
share/ramdisk.ltmpl:install "anaconda"
Comment 7 Horst H. von Brand 2011-03-06 17:43:18 EST
Then pungi didn't pull it down. The file .../logs/Fedora.x86_64.log doesn't mention anaconda, and doesn't complain it isn't there:

# grep '\(ERROR\|WARNING\)' logs/Fedora.x86_64.log
Pungi.ERROR: Group @chinese-support not found in comps!
Pungi.WARNING: Could not find a match for systemd-sysvinit in any configured repo
Pungi.WARNING: Could not find a match for swfdec in any configured repo
Pungi.WARNING: Could not find a match for xfwm4-theme-nodoka in any configured repo
Pungi.WARNING: Could not find a match for s390utils in any configured repo
Pungi.WARNING: Could not find a match for prctl in any configured repo
Pungi.WARNING: Could not find a match for silo in any configured repo
Pungi.WARNING: Could not find a match for xfwm4 in any configured repo
Pungi.WARNING: Unresolvable dependency libcelt0.so.1()(64bit) in gstreamer-plugins-bad-free.x86_64
Pungi.WARNING: Unresolvable dependency libtelepathy-logger.so.1()(64bit) in empathy.x86_64
Pungi.WARNING: Unresolvable dependency libfolks.so.20()(64bit) in empathy.x86_64
Pungi.WARNING: Unresolvable dependency libfolks-telepathy.so.20()(64bit) in empathy.x86_64
Pungi.WARNING: Unresolvable dependency libcelt0.so.1()(64bit) in gstreamer-plugins-bad-free.x86_64
Pungi.WARNING: Unresolvable dependency xfwm4 in xfdesktop.x86_64
Pungi.WARNING: Unresolvable dependency xfwm4 in xfce-utils.x86_64
Pungi.WARNING: Unresolvable dependency xfwm4 in xfdesktop.x86_64
Pungi.WARNING: Unresolvable dependency xserver-abi(videodrv-9) in xorg-x11-drv-openchrome.x86_64
Pungi.WARNING: Unresolvable dependency xserver-abi(videodrv-9) in xorg-x11-drv-qxl.x86_64
Pungi.WARNING: Unresolvable dependency xserver-abi(videodrv-9) in xorg-x11-drv-openchrome.x86_64
Pungi.WARNING: Unresolvable dependency libcelt0.so.1()(64bit) in gstreamer-plugins-bad-free.x86_64
Pungi.WARNING: Unresolvable dependency xserver-abi(videodrv-9) in xorg-x11-drv-qxl.x86_64
Comment 8 Horst H. von Brand 2011-03-06 18:44:26 EST
Just tried again, now with --releasever 15; still didn't get anaconda (it is currently downloading packages in alphabetic order, AFAICS).
Comment 9 Horst H. von Brand 2011-03-06 19:51:28 EST
Finished running pungi under Fedora rawhide for release 15: Again failure due to missing anaconda. 

# grep anaconda /usr/share/lorax/ramdisk.ltmpl
## anaconda package
install "anaconda"
remove "anaconda" "/etc/*"
remove "anaconda" "/usr/bin/*"
remove "anaconda" "/usr/share/applications/*"
remove "anaconda" "/usr/share/icons/*"

Either I'm missing something big, or you'll be in a world of hurt composing Fedora on Fedora...
Comment 10 Martin Gracik 2011-03-07 01:50:04 EST
(In reply to comment #5)
> (In reply to comment #2)
> > This means you don't have anaconda package installed in the installtree. Maybe
> > it's missing from the repo?
> 
> Hum... in rawhide/Fedora/x86_64/os/Packages/ under the directory where I ran
> pungi there is no anaconda package. Is that what you mean?

Yes, that's what I mean. You absolutely need anaconda package to make a compose. If it is not in the repo, the repo is broken/not up-to-date, or anaconda is temporarily unavailable. From the pungi log you obviously have also some unresolvable dependency problems, so other packages are missing too.

What repos are you using?
Comment 11 Horst H. von Brand 2011-03-07 08:45:58 EST
(In reply to comment #10)
 
> What repos are you using?

The ones configured by default for rawhide... I'm _not_ changing anything in the shipped .ks file (the repos are mentioned in there, aren't they?), nor have I tampered with the .repo files for my reports above.

BTW, I did install anaconda, pungi, lorax et al here for rawhide (~~-> 16) with exactly the same configurations.
Comment 12 Horst H. von Brand 2011-03-07 09:31:55 EST
(In reply to comment #10)
> (In reply to comment #5)
> > (In reply to comment #2)
> > > This means you don't have anaconda package installed in the installtree. Maybe
> > > it's missing from the repo?
> > 
> > Hum... in rawhide/Fedora/x86_64/os/Packages/ under the directory where I ran
> > pungi there is no anaconda package. Is that what you mean?
> 
> Yes, that's what I mean. You absolutely need anaconda package to make a
> compose. If it is not in the repo, the repo is broken/not up-to-date, or
> anaconda is temporarily unavailable. 

There is no mention of anaconda at all in the logs (not that it tried to get it and didn't), except for the lang-table error at the very end.

>                                      From the pungi log you obviously have also
> some unresolvable dependency problems, so other packages are missing too.

Rawhide/16 mess, I suppose. I tried with "--ver 15", there are no ERROR/WARNINGs there. It exits at the end with the same "no lang-table" error, no mention of anaconda otherwise in the log.
Comment 13 Martin Gracik 2011-03-07 09:42:56 EST
Please attach the whole log.
Comment 14 Chris Lumens 2011-03-07 15:13:42 EST
I don't think this is a pungi problem.  If you check out the results of:

        template = template.parse(tfile, tvars)

from pylorax/__init__.py, you'll see that template[0] is:

(Pdb) print template[0]
['i\x00\x00\x00n\x00\x00\x00s\x00\x00\x00t\x00\x00\x00a\x00\x00\x00l\x00\x00\x00l\x00\x00\x00', '\x00\x00\x00\x00\x00\x00a\x00\x00\x00n\x00\x00\x00a\x00\x00\x00c\x00\x00\x00o\x00\x00\x00n\x00\x00\x00d\x00\x00\x00a\x00\x00\x00\x00\x00\x00']

I think something strange is going on with the lorax/mako interaction.
Comment 15 Chris Lumens 2011-03-07 15:38:12 EST
The problem area in question in in pylorax/ltmpl.py:

 48  	        # split, strip and remove empty lines
 49  	        lines = textbuf.splitlines()
 50  	        lines = map(lambda line: line.strip(), lines)
 51  	        lines = filter(lambda line: line, lines)
 52  	
 53  	        # split with shlex
 54  	        lines = map(shlex.split, lines)

After line 51, lines is a list of unicode text.  shlex.split does not do well with that as input (see http://bugs.python.org/issue6988).  So, at the least, each element of lines needs to be converted to a regular string before calling split.  There are other possible fixes.
Comment 16 Horst H. von Brand 2011-03-07 15:39:28 EST
Created attachment 482787 [details]
Logfile with "--ver rawhide"
Comment 17 Horst H. von Brand 2011-03-07 15:40:22 EST
Created attachment 482788 [details]
With "--ver 15"
Comment 18 Horst H. von Brand 2011-03-07 15:41:36 EST
Created attachment 482790 [details]
Using "/usr/share/pungi/rawhide-fedora.ks", no --ver
Comment 19 Martin Gracik 2011-03-14 04:38:39 EDT
Fixed in lorax-0.4-1
Comment 20 Horst H. von Brand 2011-03-14 12:50:54 EDT
(In reply to comment #19)
> Fixed in lorax-0.4-1

For ~~-> 16 only?
Comment 21 Martin Gracik 2011-03-14 13:00:50 EDT
Hi, I need a blocker to push this to F15 now
Comment 22 Martin Gracik 2011-03-15 08:01:59 EDT
This should not be a problem in F15, rawhide has a newer python-mako package, the old one does not require this patch.
Comment 23 Vadym Chepkov 2012-01-27 20:51:36 EST
This problem is back in Fedora 16:


# rpm -q pungi anaconda lorax
pungi-2.9-1.fc16.noarch
anaconda-16.25-1.fc16.i686
lorax-16.4.7-2.fc16.i686

...
(507/514) [100%] installing rdate-1.4-17.fc15.i686
(508/514) [100%] installing 2:reiserfs-utils-3.6.21-4.fc15.i686
(509/514) [100%] installing 2:ntfs-3g-2011.4.12-5.fc16.i686
(510/514) [100%] installing hdparm-9.36-2.fc15.i686
(511/514) [100%] installing strace-4.6-1.fc16.i686
(512/514) [100%] installing 2:ethtool-2.6.39-1.fc16.i686
(513/514) [100%] installing rsh-0.17-65.fc15.i686
(514/514) [100%] installing vconfig-1.9-9.fc15.i686
writing .buildstamp file
removing locales
could not find anaconda lang-table, exiting
Comment 24 Philip Rhoades 2012-12-12 18:15:35 EST
I am still getting this error for F17, F18 and Rawhide even though anaconda and lorax are in x86_64/os/Packages/ and there are lines 53/54 in 
/usr/lib/python2.7/site-packages/pylorax/ltmpl.py :

 # mako template now returns unicode strings
 lines = map(lambda line: line.encode("ascii"), lines)

before lines:

 # split with shlex
 lines = map(shlex.split, lines)

Surely there must be a real fix by now?

Thanks,

Phil.

Note You need to log in before you can comment on or make changes to this bug.