Bug 68106 - kprinter crashes after adding new printer (cups)
kprinter crashes after adding new printer (cups)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-07-06 09:52 EDT by Inger Karin Haarbye
Modified: 2007-04-18 12:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-23 10:42:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Inger Karin Haarbye 2002-07-06 09:52:09 EDT
Description of Problem: 
Limbo, RedHat 7.3.92: 
 
When adding a new printer with kprinter - kprinter crash after adding the printer. The printer 
seems to work. Traceback. 
 
Version-Release number of selected component (if applicable): 
kdebase-3.0.2-0.cvs20020627.1 
 
How Reproducible: 
tried twice, once as user, once as root. 
 
Steps to Reproduce: 
1. kprinter - select add new cups-printer  
2. select port and printer 
3. When "finish" - crash with traceback. 
 
Actual Results: 
 
 
Expected Results: 
 
 
Additional Information: 
 
Traceback: 
 
(no debugging symbols found)...[New Thread 1024 (LWP 1644)] 
0x4209ce49 in wait4 () from /lib/i686/libc.so.6 
#0  0x4209ce49 in wait4 () from /lib/i686/libc.so.6 
#1  0x4211422c in __DTOR_END__ () from /lib/i686/libc.so.6 
#2  0x40f87a43 in waitpid () from /lib/i686/libpthread.so.0 
#3  0x406a5185 in KCrash::defaultCrashHandler(int) () 
   from /usr/lib/libkdecore.so.4
Comment 1 Tim Waugh 2002-08-19 13:37:44 EDT
Are you still seeing this with the current packages?
Comment 2 Ngo Than 2002-08-27 14:07:18 EDT
it's fixed in kdelib/kdebase 3.0.3-6 or newer
Comment 3 Ben Levenson 2002-09-05 17:39:19 EDT
After specifying a host and port, I am presented with the "Remote IPP printer
selection" screen. There are no printers listed, and clicking <next> tells me 
that I need to select a printer to proceed.
(Then again, I have never used this tool, so I might be doing something wrong)
FWIW, I was able to add a cups printer w/ cupsconfig: 
    HP LaserJet Series Cups v1.1

kdelibs-3.0.3-8
kdebase-3.0.3-13
Comment 4 Phil Knirsch 2003-01-23 10:42:48 EST
I really suspect a problem with the general usability of kprinter in that
respect to be honest.

You're doing everything right (i tried it too), but i can configure printers now
fine with the tool (although not very intuitively) without it crashing.

So i'm closing this bug as kprinter really doesn't crash anymore. :-)

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.