Bug 681114 - Untranslated parts on anaconda Fedora 18 Alpha
Untranslated parts on anaconda Fedora 18 Alpha
Status: CLOSED DUPLICATE of bug 858628
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 681141 682691 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-01 01:41 EST by He Rui
Modified: 2012-10-04 11:05 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 11:05:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Window 1 (71.45 KB, image/png)
2011-03-01 01:41 EST, He Rui
no flags Details
window 2 (60.55 KB, image/png)
2011-03-01 01:41 EST, He Rui
no flags Details
window 3 (214.77 KB, image/png)
2011-03-01 01:42 EST, He Rui
no flags Details
untranslated (134.08 KB, image/png)
2011-03-01 03:58 EST, bsfmig
no flags Details
untrans (110.12 KB, image/png)
2011-03-01 04:01 EST, bsfmig
no flags Details
untrans-1stb (319.27 KB, image/png)
2011-03-01 04:02 EST, bsfmig
no flags Details
untrans-smolt (329.07 KB, image/png)
2011-03-01 04:02 EST, bsfmig
no flags Details
Comfirm disk change over write dlg box has not been translated (31.68 KB, image/png)
2011-05-17 12:06 EDT, Simon Yan
no flags Details
Mis-translated Windows File Server (21.45 KB, image/png)
2011-05-17 12:08 EDT, Simon Yan
no flags Details
Typo of Fedora Packaging Program (62.92 KB, image/png)
2011-05-17 12:13 EDT, Simon Yan
no flags Details
Bad encode in unsafe root password prompt dlg box (25.27 KB, image/png)
2011-05-17 12:17 EDT, Simon Yan
no flags Details
Untranslated language strings (65.43 KB, image/png)
2011-05-17 12:19 EDT, Simon Yan
no flags Details
date and timezone selection (220.80 KB, image/png)
2012-09-28 09:54 EDT, TianShixiong
no flags Details
installation destination (37.26 KB, image/png)
2012-09-28 09:56 EDT, TianShixiong
no flags Details
installation optons (27.74 KB, image/png)
2012-09-28 09:58 EDT, TianShixiong
no flags Details
installation source (43.47 KB, image/png)
2012-09-28 10:01 EDT, TianShixiong
no flags Details
installation disks (26.97 KB, image/png)
2012-09-28 10:04 EDT, TianShixiong
no flags Details
partitions (81.34 KB, image/png)
2012-09-28 10:06 EDT, TianShixiong
no flags Details
software selection (23.65 KB, image/png)
2012-09-28 10:09 EDT, TianShixiong
no flags Details

  None (edit)
Description He Rui 2011-03-01 01:41:05 EST
Created attachment 481535 [details]
Window 1

Description of problem:
Some parts of windows on anaconda are not translated. Please refer to the attachments.

Version-Release number of selected component (if applicable):
anaconda 15.20.1

How reproducible:
100%

Steps to Reproduce:
1. Boot F15-alpha-rc2



Expected results:
Being translated to Chinese
Comment 1 He Rui 2011-03-01 01:41:32 EST
Created attachment 481536 [details]
window 2
Comment 2 He Rui 2011-03-01 01:42:00 EST
Created attachment 481537 [details]
window 3
Comment 3 Simon Yan 2011-03-01 02:33:00 EST
Window 2 has been translated on transifex.net.
Need to wait for sync up I think.

Window 3 is in comps not directly translated in Anaconda.
And the string has been translated on transifex.net too.
Comment 4 bsfmig 2011-03-01 03:58:30 EST
Created attachment 481560 [details]
untranslated
Comment 5 bsfmig 2011-03-01 04:00:49 EST
I'm uploading some other samples of untranslated strings.

另注:在Firstboot许可协议一页,“了解,请开始进行”让人不知所云;后面一些页面上,键盘快捷键处,应该是大写的地方成了小写。
Comment 6 bsfmig 2011-03-01 04:01:32 EST
Created attachment 481563 [details]
untrans
Comment 7 bsfmig 2011-03-01 04:02:11 EST
Created attachment 481564 [details]
untrans-1stb
Comment 8 bsfmig 2011-03-01 04:02:49 EST
Created attachment 481565 [details]
untrans-smolt
Comment 9 Tao Wu 2011-03-01 04:37:25 EST
(In reply to comment #0)
> Created attachment 481535 [details]
> Window 1
> 
> Description of problem:
> Some parts of windows on anaconda are not translated. Please refer to the
> attachments.
> 
> Version-Release number of selected component (if applicable):
> anaconda 15.20.1
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. Boot F15-alpha-rc2
> 
> 
> 
> Expected results:
> Being translated to Chinese

I find a similar problem, please refer to bug 681141.
Comment 10 Simon Yan 2011-03-01 04:56:51 EST
Transifex.net上看到Anaconda翻译完程度是100%。
估计等数据同步过去的build就好了。
Comment 11 Simon Yan 2011-03-01 05:18:33 EST
*** Bug 681141 has been marked as a duplicate of this bug. ***
Comment 12 TianShixiong 2011-03-01 06:36:30 EST
(In reply to comment #5)
> I'm uploading some other samples of untranslated strings.
> 
> 另注:在Firstboot许可协议一页,“了解,请开始进行”让人不知所云;后面一些页面上,键盘快捷键处,应该是大写的地方成了小写。
This is not in anaconda, but a Firstboot string. And is changed to “已了解,请继续”
Comment 13 TianShixiong 2011-03-01 10:26:11 EST
Some other related issues:

I suppose that anaconda didn't use the latest Simplified Chinese translation for this Test Day.
A lot of bot-like translated strings, which don't meet the Simplified Chinese grammar or habit, still exist in this Fedora 15 Alpha anaconda. 

Most of those bot-like translation(mentioned above) as well as some other problems were fixed after F14 release, but the fixed po file was replaced by a bad one again by someone.

I pushed the fixed one again and I'm continue updating it after translation project migrated to transifex.net.

Please consider to use this new one (listed in [1]) for Fedora 15 anaconda zh_CN translation.

[1] http://www.transifex.net/projects/p/anaconda/resource/master/
Comment 14 TianShixiong 2011-03-07 06:40:18 EST
*** Bug 682691 has been marked as a duplicate of this bug. ***
Comment 15 TianShixiong 2011-04-16 02:11:51 EDT
This is still not fixed in the recent Fedora Beta.
Please use the updated Simplified Chinese translation for anaconda.
Otherwise the installation experience of Fedora 15 in Simplified Chinese will be very bad.
Comment 16 TianShixiong 2011-04-16 02:16:46 EDT
> Steps to Reproduce:
> 1. Boot F15-alpha-rc2
> 

And also in Fedora 15 Beta RC2
Comment 17 He Rui 2011-04-17 22:57:21 EDT
(In reply to comment #15)
> This is still not fixed in the recent Fedora Beta.
> Please use the updated Simplified Chinese translation for anaconda.
> Otherwise the installation experience of Fedora 15 in Simplified Chinese will
> be very bad.

I see the bug is assigned to you. It's helpful if you reassign it to the related developer?
Comment 18 Chris Lumens 2011-04-18 08:43:00 EDT
Ah, this is likely because you guys are using the new transifex stuff for F15 translations, but we are only running "tx pull" on the master branch.  David - can you investigate pulling your patches over so we can pick up this and likely a bunch of other stuff?
Comment 19 Simon Yan 2011-05-17 02:09:46 EDT
Issues found in public beta:
1. root密码太简单时候的提示,“您的密码不够安全:???????????”
2. 确认格式化分区的时候的对话框没有翻译
3. 选择定制软件包时候,左面选择“开发”类,右面“Fedora打包程序”写成了"Fedor打包程序"
4. 选择定制软件包时候,左面选择“语言”类,右面部分内容未翻译
Comment 20 TianShixiong 2011-05-17 10:25:43 EDT
(In reply to comment #19)
> Issues found in public beta:
> 1. root密码太简单时候的提示,“您的密码不够安全:???????????”
> 2. 确认格式化分区的时候的对话框没有翻译
> 3. 选择定制软件包时候,左面选择“开发”类,右面“Fedora打包程序”写成了"Fedor打包程序"
> 4. 选择定制软件包时候,左面选择“语言”类,右面部分内容未翻译

Please use English if you want all to understand what you said.
All of the anaconda are properly translated. I will check the "Fedor打包程序". 
And I saw you locked the po now. And anaconda updated few lines. 
So please help to see it.
Comment 21 TianShixiong 2011-05-17 10:37:36 EDT
(In reply to comment #20)
> (In reply to comment #19)
> > Issues found in public beta:
> > 1. root密码太简单时候的提示,“您的密码不够安全:???????????”
> > 2. 确认格式化分区的时候的对话框没有翻译
> > 3. 选择定制软件包时候,左面选择“开发”类,右面“Fedora打包程序”写成了"Fedor打包程序"

Please paste a screenshot if possible, Cause I didn't and couldn't find "Fedor打包程序" in anaconda zh_CN.po file.

I don't think this is an error in anaconda translation.
While you do install, other programs may be also run besides anaconda.
Comment 22 Simon Yan 2011-05-17 11:47:07 EDT

(In reply to comment #21)
> (In reply to comment #20)
> > (In reply to comment #19)
> > > Issues found in public beta:
> > > 1. root密码太简单时候的提示,“您的密码不够安全:???????????”
> > > 2. 确认格式化分区的时候的对话框没有翻译
> > > 3. 选择定制软件包时候,左面选择“开发”类,右面“Fedora打包程序”写成了"Fedor打包程序"
> 
> Please paste a screenshot if possible, Cause I didn't and couldn't find
> "Fedor打包程序" in anaconda zh_CN.po file.
> 
> I don't think this is an error in anaconda translation.
> While you do install, other programs may be also run besides anaconda.

If I'm looking at the right place, I could not find it either from the po file. (https://www.transifex.net/projects/p/anaconda/resource/f15-branch/l/zh_CN/view/) Could it be because the public beta is not using the latest po?
Comment 23 Simon Yan 2011-05-17 11:51:05 EDT
By a bit more searching, I can tell the public build is definitely not using the latest PO from transifex.net. How do I know? In the installation process, I did saw a couple of untranslated strings but when I search on transifex.net it appears all of them have been properly translated.

So my question is, how come?
Comment 24 Simon Yan 2011-05-17 12:06:52 EDT
Created attachment 499402 [details]
Comfirm disk change over write dlg box has not been translated

Attaching screenshots of a few translation issues I spotted during Fedora 15 public beta install.
Comment 25 Simon Yan 2011-05-17 12:08:19 EDT
Created attachment 499403 [details]
Mis-translated Windows File Server

Attaching screenshots of a few translation issues I spotted during Fedora 15 public beta install.
Comment 26 Simon Yan 2011-05-17 12:13:37 EDT
Created attachment 499405 [details]
Typo of Fedora Packaging Program
Comment 27 Simon Yan 2011-05-17 12:17:06 EDT
Created attachment 499406 [details]
Bad encode in unsafe root password prompt dlg box
Comment 28 Simon Yan 2011-05-17 12:19:01 EDT
Created attachment 499407 [details]
Untranslated language strings
Comment 29 David Cantrell 2011-05-17 14:00:47 EDT
(In reply to comment #23)
> By a bit more searching, I can tell the public build is definitely not using
> the latest PO from transifex.net. How do I know? In the installation process, I
> did saw a couple of untranslated strings but when I search on transifex.net it
> appears all of them have been properly translated.
> 
> So my question is, how come?

If the strings were updated on transifex.net after Fedora 15 Beta was released, then the changes will not show up in anaconda until the final release of Fedora 15.
Comment 30 Simon Yan 2011-05-17 20:45:02 EDT
(In reply to comment #29)
> (In reply to comment #23)
> > By a bit more searching, I can tell the public build is definitely not using
> > the latest PO from transifex.net. How do I know? In the installation process, I
> > did saw a couple of untranslated strings but when I search on transifex.net it
> > appears all of them have been properly translated.
> > 
> > So my question is, how come?
> 
> If the strings were updated on transifex.net after Fedora 15 Beta was released,
> then the changes will not show up in anaconda until the final release of Fedora
> 15.

It's unlikely the strings are updated after Fedora 15 Beta was releases. In comment 10 I've already updated that the anaconda translation is 100% done. That is over 2 months back. (Sorry, that comment was in Chinese)
Comment 31 TianShixiong 2011-05-17 21:07:08 EDT
(In reply to comment #30)
 (In reply to comment #29)
> > 
> > If the strings were updated on transifex.net after Fedora 15 Beta was released,
> > then the changes will not show up in anaconda until the final release of Fedora
> > 15.
> 
> It's unlikely the strings are updated after Fedora 15 Beta was releases. In
> comment 10 I've already updated that the anaconda translation is 100% done.
> That is over 2 months back. (Sorry, that comment was in Chinese)
I updated it several times as long as anaconda made new change since the beta release. It was changed again yesterday after you locked it. I will update the translation again when you unlock it or you can help to update that too ;)

So I hope everything will be right displayed when the final release.
Comment 32 Simon Yan 2011-05-17 21:57:18 EDT
(In reply to comment #31)
> (In reply to comment #30)
>  (In reply to comment #29)
> > > 
> > > If the strings were updated on transifex.net after Fedora 15 Beta was released,
> > > then the changes will not show up in anaconda until the final release of Fedora
> > > 15.
> > 
> > It's unlikely the strings are updated after Fedora 15 Beta was releases. In
> > comment 10 I've already updated that the anaconda translation is 100% done.
> > That is over 2 months back. (Sorry, that comment was in Chinese)
> I updated it several times as long as anaconda made new change since the beta
> release. It was changed again yesterday after you locked it. I will update the
> translation again when you unlock it or you can help to update that too ;)
> 
> So I hope everything will be right displayed when the final release.

I don't remember I have locked it. So please feel free to do what's needed.
Comment 33 Simon Yan 2011-05-17 22:00:57 EDT
(In reply to comment #31)
> (In reply to comment #30)
>  (In reply to comment #29)
> > > 
> > > If the strings were updated on transifex.net after Fedora 15 Beta was released,
> > > then the changes will not show up in anaconda until the final release of Fedora
> > > 15.
> > 
> > It's unlikely the strings are updated after Fedora 15 Beta was releases. In
> > comment 10 I've already updated that the anaconda translation is 100% done.
> > That is over 2 months back. (Sorry, that comment was in Chinese)
> I updated it several times as long as anaconda made new change since the beta
> release. It was changed again yesterday after you locked it. I will update the
> translation again when you unlock it or you can help to update that too ;)
> 
> So I hope everything will be right displayed when the final release.

Sorry, my bad, I did have locked Anaconda Master. So the latest Fedora build is pulling PO file from Master branch? I though it should do it from f15-branch. Pulling from Master does not make any sense.
Comment 34 Simon Yan 2011-05-18 07:17:34 EDT
I'm glad to report all the issues I reported have been fixed in Fedora 15 RC3 except for item 1.
Comment 35 TianShixiong 2011-05-25 10:19:51 EDT
(In reply to comment #0)
> Created attachment 481535 [details]
> Window 1
> 

This problem(Please see attachment 481535 [details]) still exist in Fedora 15 final release.
Anaconda version:15.31

Test Media: Fedora-15-i386-netinst.iso
I didn't test this on DVD media.

I thinks the related strings in the PO file is:
'You have provided a weak password: %s '

 '%s' in the string is not shown properly.
Comment 36 TianShixiong 2012-06-21 09:47:48 EDT
The problem still happens in Fedora 17.

Test Media:Fedora-17-x86_64-netinst.iso

A lot of strings are still shown in English, including Back/Next navigation button during installation.

Translation was completed well on transifex.net before Fedora 17 final release.
Comment 37 Piotr Drąg 2012-09-06 18:50:52 EDT
Anaconda's UI has been completely re-written recently, so please check if it still happens in Fedora 18.

(In reply to comment #36)
> The problem still happens in Fedora 17.
> A lot of strings are still shown in English, including Back/Next navigation
> button during installation.

It's well known bug, apparently fixed in Fedora 18. There is nothing that can be done in F17 anymore.
Comment 38 TianShixiong 2012-09-28 09:54:40 EDT
Created attachment 618586 [details]
date and timezone selection

network tiem/region/city are English
They should be in Chinese.
Comment 39 TianShixiong 2012-09-28 09:55:16 EDT
I tested the translation again on Fedora 18 Alpha l10n by using bfo(boot.fedoraproject.org) today.
Most of the string are still in English or partly translated after I selected Chinese from the language list.
Please see the details from the latest uploaded screenshots.

Due to the software selection can't be done, I couldn't continue to the next screen, so I didn't test the rest of the screens.
Comment 40 TianShixiong 2012-09-28 09:56:55 EDT
Created attachment 618594 [details]
installation destination

back/continue buttons and the string at the bottom should be in Chinese
Comment 41 TianShixiong 2012-09-28 09:58:59 EDT
Created attachment 618602 [details]
installation optons

The buttons and last string should be in Chinese.
Comment 42 TianShixiong 2012-09-28 10:01:43 EDT
Created attachment 618614 [details]
installation source

All of the strings should be in Chinese.
Comment 43 TianShixiong 2012-09-28 10:04:17 EDT
Created attachment 618615 [details]
installation disks

All the words should be in Chinese
Comment 44 TianShixiong 2012-09-28 10:06:15 EDT
Created attachment 618616 [details]
partitions
Comment 45 TianShixiong 2012-09-28 10:09:33 EDT
Created attachment 618617 [details]
software selection

buttons and the strings
Also the blank "environment choose" prevented me from continuing the installation.
Comment 46 TianShixiong 2012-09-28 10:18:58 EDT
(In reply to comment #39)
> I tested the translation again on Fedora 18 Alpha l10n by using
> bfo(boot.fedoraproject.org) today.
> Most of the string are still in English or partly translated after I
> selected Chinese from the language list.
> Please see the details from the latest uploaded screenshots.
> 
> Due to the software selection can't be done, I couldn't continue to the next
> screen, so I didn't test the rest of the screens.

By the way, my test Fedora 18 Alpha architect is i386.
Comment 47 Chris Lumens 2012-10-04 11:05:32 EDT

*** This bug has been marked as a duplicate of bug 858628 ***

Note You need to log in before you can comment on or make changes to this bug.