Bug 681127 - SELinux is preventing systemd-readahe from 'write' accesses on the directory /var/spool/cron.
SELinux is preventing systemd-readahe from 'write' accesses on the directory ...
Status: CLOSED DUPLICATE of bug 669672
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:e5df2b6ec62...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-01 02:52 EST by Lukas Bezdicka
Modified: 2011-03-01 07:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-01 07:28:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Bezdicka 2011-03-01 02:52:28 EST
SELinux is preventing systemd-readahe from 'write' accesses on the directory /var/spool/cron.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that systemd-readahe should be allowed write access on the cron directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep systemd-readahe /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:readahead_t:s0
Target Context                system_u:object_r:cron_spool_t:s0
Target Objects                /var/spool/cron [ dir ]
Source                        systemd-readahe
Source Path                   systemd-readahe
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           cronie-1.4.6-9.fc15
Policy RPM                    selinux-policy-3.9.15-2.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 2.6.38-0.rc6.git4.1.fc15.x86_64
                              #1 SMP Fri Feb 25 03:46:42 UTC 2011 x86_64 x86_64
Alert Count                   1
First Seen                    Tue 01 Mar 2011 08:45:14 AM CET
Last Seen                     Tue 01 Mar 2011 08:45:14 AM CET
Local ID                      363209a8-6bfa-4d08-beeb-59656df5a51d

Raw Audit Messages
type=AVC msg=audit(1298965514.220:27): avc:  denied  { write } for  pid=335 comm="systemd-readahe" path="/var/spool/cron" dev=sda2 ino=24582 scontext=system_u:system_r:readahead_t:s0 tcontext=system_u:object_r:cron_spool_t:s0 tclass=dir


Hash: systemd-readahe,readahead_t,cron_spool_t,dir,write

audit2allow

#============= readahead_t ==============
#!!!! The source type 'readahead_t' can write to a 'dir' of the following types:
# readahead_var_lib_t, readahead_var_run_t, root_t, device_t, var_run_t, root_t

allow readahead_t cron_spool_t:dir write;

audit2allow -R

#============= readahead_t ==============
#!!!! The source type 'readahead_t' can write to a 'dir' of the following types:
# readahead_var_lib_t, readahead_var_run_t, root_t, device_t, var_run_t, root_t

allow readahead_t cron_spool_t:dir write;
Comment 1 Miroslav Grepl 2011-03-01 07:28:43 EST
You can try to install the latest F15 policy from koji for now

http://koji.fedoraproject.org/koji/buildinfo?buildID=230829

*** This bug has been marked as a duplicate of bug 669672 ***

Note You need to log in before you can comment on or make changes to this bug.