This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 68117 - Mouse stops functioning after X sits for a long time
Mouse stops functioning after X sits for a long time
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-06 12:24 EDT by Michael Eckhoff
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-03 15:49:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X Configuration File after install (3.21 KB, text/plain)
2002-07-09 22:59 EDT, Michael Eckhoff
no flags Details
Process Listing (3.74 KB, text/plain)
2002-08-07 22:24 EDT, Michael Eckhoff
no flags Details
xdpyinfo output (2.50 KB, text/plain)
2002-08-07 22:26 EDT, Michael Eckhoff
no flags Details

  None (edit)
Description Michael Eckhoff 2002-07-06 12:24:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
If I walk away from the computer for a few hours (not sure exactly how long yet)
when I come back, the mouse does not function.  Switching to a text console and
moving the mouse will trigger gpm after a second.  I can then switch back to X11
and it will function properly again.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.  Idle X11
2.  Return to system and move mouse
3.  Switch to text console, move mouse, and switch back to regain mouse control.
	

Actual Results:  The mouse will idle out and no longer function in X11 after the
system idles for a while.

Expected Results:  The mouse should work.

Additional info:

Switching to a text console and triggering gpm will bring the mouse back in X. 
Also, I have a USB keyboard and PS/2 mouse.  There is nothing plugged into the
PS/2 keyboard port.  During the install, this also caused problems with the
mouse not responding at all and I had to use a USB mouse.  I have not checked to
see if using a USB mouse will eliminate this hang.
Comment 1 Mike A. Harris 2002-07-09 20:52:21 EDT
Please attach your X server config and log file using the link below.
Comment 2 Michael Eckhoff 2002-07-09 22:59:44 EDT
Created attachment 64504 [details]
X Configuration File after install
Comment 3 Michael Eckhoff 2002-07-09 23:05:30 EDT
As an additional observation, I reinstalled off of a bootable CD and only
installed KDE this time.  Prior to that, I had installed Gnome and KDE both.

My login manager is now kdm and I don't see the problems with the mouse hanging
that I did when I was running Gnome/gdm.

If you'd like, I can reinstall again with Gnome/gdm and see if the problem comes
back?
Comment 4 Mike A. Harris 2002-07-26 03:25:11 EDT
You did not supply your X server log file as requested.  Please
attach it to the bug report so I can examine it.

Does the mouse just stop working, or does the entire X server stop
working?  Does the keyboard still work at all?

Also, are you running xscreensaver?  Is DPMS enabled or disabled?

Are you using APM suspend/resume?
Comment 5 Mike A. Harris 2002-08-06 04:50:09 EDT
ping
Comment 6 Michael Eckhoff 2002-08-07 22:24:34 EDT
Created attachment 69444 [details]
Process Listing
Comment 7 Michael Eckhoff 2002-08-07 22:25:09 EDT
Please see the attached Xconfig, xdpyinfo output, and process list.

Only the mouse stops working.  If I force kill X with control-alt-backspace,
when it reloads, it's fine again.  It also does it right after a logout.  So,
for instance, I may be working fine, logout, and when the new redhat login
screen shows up, the mouse doesn't work.  I force kill X, it restarts, and the
mouse is fine again.

xscreensaver is loaded, but does not have to be activated for this to happen.

I am not using APM Suspend/Resume.

-- sorry it took so long to get this data to you.  I had to reinstall the beta
again to get it.  I had gone back to 7.3 for stability. --
Comment 8 Michael Eckhoff 2002-08-07 22:26:53 EDT
Created attachment 69445 [details]
xdpyinfo output
Comment 9 Mike A. Harris 2002-08-16 07:15:32 EDT
Does the keyboard still work at all when this occurs?

Comment 10 Michael Eckhoff 2002-08-21 23:27:43 EDT
Yes, the keyboard works fine.  In fact, the following is probably the simplest
way to reproduce it and kick it in gear again:

from boot...

1)  init 5 - let gdm start up with the special redhat login screen that is there
now.

Note: The mouse should work at this point

2)  Login to Gnome.  The mouse will still work.
3)  Logout of Gnome.  The mouse will  NOT WORK anymore as soon as gdm picks back up.

At this point, you can just log back in since the keyboard still works.  Gnome
will start and the mouse will still NOT work.

Switch to a normal console like ctrl-alt-f1 and then back to alt-f7 and the
mouse will be fine again.
Comment 11 Michael Eckhoff 2002-08-21 23:49:15 EDT
Ok - This is interesting.

If I plug in a PS/2 keyboard - don't use it - just plug it in since I normally
use a USB only keyboard, the problem goes away.  The mouse works just fine going
in and out of Gnome/gdm.
Comment 12 Mike A. Harris 2002-11-03 05:46:27 EST
Are you using a KVM switch at all?
Comment 13 Michael Eckhoff 2002-11-03 15:49:00 EST
I am not using a KVM.  The problem appears to have gone away with 8.0 release. 
I just reinstalled it today, unplugged the PS/2 keyboard that was making it keep
working with (null) and everything seems fine on a USB-only system.
Comment 14 Mike A. Harris 2002-11-04 00:36:46 EST
Ok, I'm writing it off to either hardware flakiness, weirdo BIOS, or perhaps
kernel bug, or kernel workaround for hardware issue.  Nothing in X has
changed, so it wasn't likely X related.

Closing as CURRENTRELEASE 8.0.

Thanks

Note You need to log in before you can comment on or make changes to this bug.