Bug 681199 - show current keyboard keymap/layout status when inputting password
show current keyboard keymap/layout status when inputting password
Status: CLOSED DUPLICATE of bug 582536
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: i18n, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-01 07:31 EST by Yulia Kopkova
Modified: 2011-05-19 09:25 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:25:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yulia Kopkova 2011-03-01 07:31:21 EST
Description of problem:
Anaconda do not show any tooltip about what is the current keymap. In that case one can input passphrase to encrypt partition using for example Russian language. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Fedora
2. Choose Russian keymap
3. Continue to input passphrase for partition encryption
  
Actual results:
No hint about what is the current keymap. It could be Russian/Enflish

Expected results:
Hint about current keymap

Additional info:
Comment 1 Chris Lumens 2011-03-01 09:46:54 EST
anaconda just uses the system-config-keyboard screen, so any change would need to be made there.
Comment 2 Jens Petersen 2011-05-15 22:55:50 EDT
Well I think the RFE is to show the current kbd layout in use
when inputting passwords, etc, since the input can't be seen.
(If it could display "US" or "RU" then it would be clear:
better would be to force password input widgets to use an ASCII layout,
but I think GTK still lacks such an API.  I think I have
seen the former with gnome-screensaver?)
Comment 3 Jens Petersen 2011-05-19 01:31:47 EDT
Perhaps this should be moved to gtk3?

Or we should support or avoid keyboard layout switching to non-ascii layouts inside anaconda?
Comment 4 Chris Lumens 2011-05-19 09:25:18 EDT

*** This bug has been marked as a duplicate of bug 582536 ***

Note You need to log in before you can comment on or make changes to this bug.