Bug 681231 - texlive-asymptote (from TeXlive 2011) doesn't provide the binaries (?)
Summary: texlive-asymptote (from TeXlive 2011) doesn't provide the binaries (?)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-01 14:01 UTC by Horst H. von Brand
Modified: 2013-07-02 23:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-07 08:23:50 UTC


Attachments (Terms of Use)

Description Horst H. von Brand 2011-03-01 14:01:42 UTC
Description of problem:
On updating, the package asymptote is now gone for rawhide (at least), replaced by texlive-asymptote. But those are only a bunch of noarch packages (including the manpages for asy asn xasy!) but no binaries.

Version-Release number of selected component (if applicable):
texlive-asymptote-2011-0.1.2.02.svn19472.fc14.noarch

How reproducible:
Always...

Steps to Reproduce:
1. asy
2.
3.
  
Actual results:
Program not found

Expected results:


Additional info:

Comment 1 Jindrich Novy 2011-03-02 14:31:30 UTC
The problem is that TeX Live upstream doesn't ship asymptote in its sources. On the other hand it contains all the noarch bits. So I'm not quite sure what are upstream intentions. Maybe we need to ask.

Comment 2 Horst H. von Brand 2011-03-02 15:01:58 UTC
(In reply to comment #1)
> The problem is that TeX Live upstream doesn't ship asymptote in its sources. On
> the other hand it contains all the noarch bits. So I'm not quite sure what are
> upstream intentions. Maybe we need to ask.

That is seriously out of whack, as it includes manpages (!) but no binaries...

Comment 3 Jindrich Novy 2011-03-03 08:14:05 UTC
Indeed. At least I removed the Obsoletes/Provides so that the stock Fedora asymptote will not be obsoleted by the broken TL2010/TL2011 one for now.

This change will occur in the next repo update.

Comment 4 Jindrich Novy 2012-10-07 08:23:50 UTC
Asymptote is now completely removed from TeX Live 2012 in rawhide as there is separate asymptote package in Fedora already. Maybe I will talk to asymptote maintainer and propose him to move to TeX Live's variant of asymptote also in Fedora.


Note You need to log in before you can comment on or make changes to this bug.