Bug 681242 - traceback with incorrect option
Summary: traceback with incorrect option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-packager
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 682497 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-01 14:21 UTC by Marcela Mašláňová
Modified: 2013-01-10 06:29 UTC (History)
4 users (show)

Fixed In Version: fedora-packager-0.5.7.0-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-10 03:14:14 UTC


Attachments (Terms of Use)

Description Marcela Mašláňová 2011-03-01 14:21:18 UTC
Description of problem:
traceback with incorrect option

Version-Release number of selected component (if applicable):
fedpkg-0.5.6.0-1.fc14.noarch

How reproducible:
fedpkg help
Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 1480, in <module>
    args.command(args)
  File "/usr/bin/fedpkg", line 145, in usage
    parser.print_help()
NameError: global name 'parser' is not defined
  
Actual results:
traceback

Expected results:
nice error message

Comment 1 Jesse Keating 2011-03-01 17:28:21 UTC
Yeah, this bug came up when we added support for generating a man page.  As a workaround you can do "fedpkg --help" instead.  I'll get this fixed in the next release.

Comment 2 Hans Ulrich Niedermann 2011-03-02 12:08:55 UTC
This came up on #fedora-devel a few weeks ago, and the fix has been at

   git://fedorapeople.org/~ndim/fedora-packager.git
   branch fix-help-command

ever since.

Another related "fedpkg help" issue came up in that IRC conversation as well, which I implemented in the "help-command-with-subcommands" branch: That also makes "fedpkg help srpm" work, including bash tab completion.

Comment 3 Jesse Keating 2011-03-04 00:21:12 UTC
hrm, I can see how the commit fixes fedpkg help, but how does it do anything for tab completion after help?  Is there another commit somewhere?

I cherry-picked 4c5d0003ca3cace64ea780ca4121c46487b5899e over to my bugfix branch and will push it soon.

Comment 4 Hans Ulrich Niedermann 2011-03-04 23:20:34 UTC
(In reply to comment #3)
> hrm, I can see how the commit fixes fedpkg help, but how does it do anything
> for tab completion after help?  Is there another commit somewhere?

As I wrote, the fix (which you found) is in the "fix-help-command" branch.

The "fedpkg help foo" stuff including bash completion is in a separate branch called "help-command-with-subcommands", to separate bugfix from feature.
 
> I cherry-picked 4c5d0003ca3cace64ea780ca4121c46487b5899e over to my bugfix
> branch and will push it soon.

Which should close this bug. Good.

Comment 5 Hans Ulrich Niedermann 2011-03-06 12:15:16 UTC
*** Bug 682497 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2011-03-07 23:27:34 UTC
fedora-packager-0.5.7.0-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.7.0-1.fc13

Comment 7 Fedora Update System 2011-03-07 23:28:40 UTC
fedora-packager-0.5.7.0-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.7.0-1.fc14

Comment 8 Fedora Update System 2011-03-07 23:30:21 UTC
fedora-packager-0.5.7.0-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.7.0-1.fc15

Comment 9 Fedora Update System 2011-03-08 02:21:11 UTC
fedora-packager-0.5.7.0-1.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fedora-packager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/fedora-packager-0.5.7.0-1.fc15

Comment 10 Fedora Update System 2011-03-10 03:13:57 UTC
fedora-packager-0.5.7.0-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-03-22 18:49:42 UTC
fedora-packager-0.5.7.0-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-03-22 18:54:53 UTC
fedora-packager-0.5.7.0-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.