This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 681267 - AttributeError: 'module' object has no attribute 'findExistingRoots'
AttributeError: 'module' object has no attribute 'findExistingRoots'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
anaconda_trace_hash:e8bb8abea2ea190c1...
:
: 683982 (view as bug list)
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-03-01 10:51 EST by Kamil Páral
Modified: 2011-04-05 17:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-15.26-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-05 17:39:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (287.67 KB, text/plain)
2011-03-01 10:51 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2011-03-01 10:51:00 EST
The following was filed automatically by anaconda:
anaconda 15.20.1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/examine_gui.py", line 101, in getScreen
    (self.anaconda.rootParts, notUpgradable) = upgrade.findExistingRoots(self.anaconda,
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1338, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1249, in prevClicked
    self.setScreen ()
AttributeError: 'module' object has no attribute 'findExistingRoots'
Comment 1 Kamil Páral 2011-03-01 10:51:08 EST
Created attachment 481664 [details]
Attached traceback automatically from anaconda.
Comment 2 Kamil Páral 2011-03-01 10:52:45 EST
This happened when I went up to the step where I enter encryption phrase for my new system, and then clicked Cancel, Back, Back, Back, ... crash.
Comment 3 Brian Lane 2011-03-01 12:38:21 EST
Give this update a try, add this to the kernel command line:

updates=http://bcl.fedorapeople.org/updates/681267.img
Comment 4 Kamil Páral 2011-03-02 06:54:10 EST
One more detail: The crash happens only if I have previous Fedora installation on the disk (and I choose Fresh install).

With the updates.img applied I couldn't reproduce the crash, so I believe you fixed it.
Comment 5 Chris Lumens 2011-03-10 15:47:55 EST
*** Bug 683982 has been marked as a duplicate of this bug. ***
Comment 6 James Laska 2011-03-11 14:41:47 EST
Discussed at 2011-03-11 blocker review meeting.  This issue is fixed and available for testing in anaconda-15.21-1.  The issue has been accepted as a beta blocker.
Comment 7 Fedora Update System 2011-03-29 16:59:05 EDT
anaconda-15.26-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
Comment 8 Fedora Update System 2011-03-29 22:25:58 EDT
Package anaconda-15.26-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-15.26-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2011-04-05 17:37:53 EDT
anaconda-15.26-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.