Bug 681305 - httpd crashes on POST request
Summary: httpd crashes on POST request
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: 15
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-01 18:28 UTC by Vasile Chelban
Modified: 2011-03-25 07:07 UTC (History)
3 users (show)

Fixed In Version: apr-1.4.2-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-25 07:07:14 UTC


Attachments (Terms of Use)
HTTPD stacktrace (4.13 KB, text/plain)
2011-03-01 18:28 UTC, Vasile Chelban
no flags Details

Description Vasile Chelban 2011-03-01 18:28:37 UTC
Created attachment 481700 [details]
HTTPD stacktrace

Description of problem:


Version-Release number of selected component (if applicable):
httpd-2.2.17-8.fc15.i686

How reproducible:
Always

Steps to Reproduce:
1. create a simple html file with post form in /var/www/html/1.html
<html>
<body>
<form method=POST action="">
<input type="text" value="test" name="ttt">
</form>
</body>
</html>

2. run httpd service
 # service httpd start
3. Access local page http://localhost/1.html and send form with Enter key
  
Actual results:
 Empty page, and /var/log/httpd/error_log contains
[Tue Mar 01 19:52:23 2011] [notice] child pid 16208 exit signal Segmentation fault (11)


Expected results:
 The same form


Additional info:
 stacktrace attached

Comment 1 Joe Orton 2011-03-04 16:20:42 UTC
Thanks for the report.  I suspect this is caused by 

https://issues.apache.org/bugzilla/show_bug.cgi?id=50190

I am preparing F15 updates; if you are adventurous you could try the rawhide builds:

http://koji.fedoraproject.org/koji/buildinfo?buildID=231644
http://koji.fedoraproject.org/koji/buildinfo?buildID=232037
http://koji.fedoraproject.org/koji/buildinfo?buildID=231705

Comment 2 Vasile Chelban 2011-03-06 09:33:04 UTC
Yes, it works.

Comment 3 Fedora Update System 2011-03-07 09:55:50 UTC
apr-1.4.2-3.fc15, apr-util-1.3.10-5.fc15, httpd-2.2.17-10.fc15.1 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/httpd-2.2.17-10.fc15.1,apr-util-1.3.10-5.fc15,apr-1.4.2-3.fc15

Comment 4 Fedora Update System 2011-03-08 02:20:45 UTC
apr-1.4.2-3.fc15, apr-util-1.3.10-5.fc15, httpd-2.2.17-10.fc15.1 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update apr apr-util httpd'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/httpd-2.2.17-10.fc15.1,apr-util-1.3.10-5.fc15,apr-1.4.2-3.fc15

Comment 5 Fedora Update System 2011-03-25 07:07:07 UTC
apr-1.4.2-3.fc15, apr-util-1.3.10-5.fc15, httpd-2.2.17-10.fc15.1 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.