Bug 681337 - FOP exception occurs every time I compile pdf documents via publican
Summary: FOP exception occurs every time I compile pdf documents via publican
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fop
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ruediger Landmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-01 20:28 UTC by Anica
Modified: 2011-09-25 03:30 UTC (History)
5 users (show)

Fixed In Version: fop-1.0-17.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-25 03:30:44 UTC


Attachments (Terms of Use)

Description Anica 2011-03-01 20:28:03 UTC
Description of problem:
I tried to compile a few documents using the fedira 15 alpha and I encountered this exception every time.  The documents build correctly in fedora 14. I *believe* I have configured fedora 15 correctly.

Version-Release number of selected component (if applicable):
fop 0.95-5

How reproducible:
100%

Steps to Reproduce:
1. Run publican to build documents as pdf files.
  
Actual results:
SEVERE: javax.xml.transform.TransformerException: Value must not be
empty
Mar 1, 2011 2:27:43 PM org.apache.fop.cli.Main startFOP
SEVERE: Exception
org.apache.fop.apps.FOPException: org.xml.sax.SAXException: Value must
not be empty
java.lang.IllegalArgumentException: Value must not be empty
javax.xml.transform.TransformerException: org.xml.sax.SAXException:
Value must not be empty
java.lang.IllegalArgumentException: Value must not be empty
        at
org.apache.fop.cli.InputHandler.transformTo(InputHandler.java:217)
        at
org.apache.fop.cli.InputHandler.renderTo(InputHandler.java:125)
        at org.apache.fop.cli.Main.startFOP(Main.java:166)
        at org.apache.fop.cli.Main.main(Main.java:196)
Caused by: javax.xml.transform.TransformerException:
org.xml.sax.SAXException: Value must not be empty
java.lang.IllegalArgumentException: Value must not be empty
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:723)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:317)
        at
org.apache.fop.cli.InputHandler.transformTo(InputHandler.java:214)
        ... 3 more
Caused by: org.xml.sax.SAXException: Value must not be empty
java.lang.IllegalArgumentException: Value must not be empty
        at org.apache.fop.fo.FOTreeBuilder
$MainFOHandler.startElement(FOTreeBuilder.java:297)
        at
org.apache.fop.fo.FOTreeBuilder.startElement(FOTreeBuilder.java:163)
        at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.closeStartTag(ToXMLSAXHandler.java:208)
        at
com.sun.org.apache.xml.internal.serializer.ToSAXHandler.flushPending(ToSAXHandler.java:281)
        at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.startElement(ToXMLSAXHandler.java:650)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:504)
        at
com.sun.org.apache.xerces.internal.xinclude.XIncludeHandler.startElement(XIncludeHandler.java:911)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(XMLNSDocumentScannerImpl.java:376)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl
$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2732)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:625)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:116)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:488)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:812)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:741)
        at
com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:123)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1208)
        at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl
$JAXPSAXParser.parse(SAXParserImpl.java:525)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transformIdentity(TransformerImpl.java:640)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:711)
        ... 5 more
Caused by: java.lang.IllegalArgumentException: Value must not be empty
        at
org.apache.xmlgraphics.xmp.XMPSchemaAdapter.addStringToArray(XMPSchemaAdapter.java:79)
        at
org.apache.xmlgraphics.xmp.XMPSchemaAdapter.addStringToSeq(XMPSchemaAdapter.java:142)
        at
org.apache.xmlgraphics.xmp.schemas.DublinCoreAdapter.addCreator(DublinCoreAdapter.java:106)
        at
org.apache.fop.pdf.PDFMetadata.createXMPFromPDFDocument(PDFMetadata.java:140)
        at
org.apache.fop.render.pdf.PDFRenderer.renderXMPMetadata(PDFRenderer.java:618)
        at
org.apache.fop.render.pdf.PDFRenderer.processOffDocumentItem(PDFRenderer.java:557)
        at
org.apache.fop.area.RenderPagesModel.handleOffDocumentItem(RenderPagesModel.java:207)
        at
org.apache.fop.area.AreaTreeHandler.addOffDocumentItem(AreaTreeHandler.java:338)
        at
org.apache.fop.area.AreaTreeHandler.wrapAndAddExtensionAttachments(AreaTreeHandler.java:213)
        at
org.apache.fop.area.AreaTreeHandler.startAbstractPageSequence(AreaTreeHandler.java:205)
        at
org.apache.fop.area.AreaTreeHandler.startPageSequence(AreaTreeHandler.java:194)
        at
org.apache.fop.fo.pagination.PageSequence.startOfNode(PageSequence.java:114)
        at org.apache.fop.fo.FOTreeBuilder
$MainFOHandler.startElement(FOTreeBuilder.java:295)
        ... 23 more

---------

javax.xml.transform.TransformerException: org.xml.sax.SAXException:
Value must not be empty
java.lang.IllegalArgumentException: Value must not be empty
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:723)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:317)
        at
org.apache.fop.cli.InputHandler.transformTo(InputHandler.java:214)
        at
org.apache.fop.cli.InputHandler.renderTo(InputHandler.java:125)
        at org.apache.fop.cli.Main.startFOP(Main.java:166)
        at org.apache.fop.cli.Main.main(Main.java:196)
Caused by: org.xml.sax.SAXException: Value must not be empty
java.lang.IllegalArgumentException: Value must not be empty
        at org.apache.fop.fo.FOTreeBuilder
$MainFOHandler.startElement(FOTreeBuilder.java:297)
        at
org.apache.fop.fo.FOTreeBuilder.startElement(FOTreeBuilder.java:163)
        at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.closeStartTag(ToXMLSAXHandler.java:208)
        at
com.sun.org.apache.xml.internal.serializer.ToSAXHandler.flushPending(ToSAXHandler.java:281)
        at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.startElement(ToXMLSAXHandler.java:650)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:504)
        at
com.sun.org.apache.xerces.internal.xinclude.XIncludeHandler.startElement(XIncludeHandler.java:911)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(XMLNSDocumentScannerImpl.java:376)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl
$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2732)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:625)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:116)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:488)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:812)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:741)
        at
com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:123)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1208)
        at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl
$JAXPSAXParser.parse(SAXParserImpl.java:525)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transformIdentity(TransformerImpl.java:640)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:711)
        ... 5 more
Caused by: java.lang.IllegalArgumentException: Value must not be empty
        at
org.apache.xmlgraphics.xmp.XMPSchemaAdapter.addStringToArray(XMPSchemaAdapter.java:79)
        at
org.apache.xmlgraphics.xmp.XMPSchemaAdapter.addStringToSeq(XMPSchemaAdapter.java:142)
        at
org.apache.xmlgraphics.xmp.schemas.DublinCoreAdapter.addCreator(DublinCoreAdapter.java:106)
        at
org.apache.fop.pdf.PDFMetadata.createXMPFromPDFDocument(PDFMetadata.java:140)
        at
org.apache.fop.render.pdf.PDFRenderer.renderXMPMetadata(PDFRenderer.java:618)
        at
org.apache.fop.render.pdf.PDFRenderer.processOffDocumentItem(PDFRenderer.java:557)
        at
org.apache.fop.area.RenderPagesModel.handleOffDocumentItem(RenderPagesModel.java:207)
        at
org.apache.fop.area.AreaTreeHandler.addOffDocumentItem(AreaTreeHandler.java:338)
        at
org.apache.fop.area.AreaTreeHandler.wrapAndAddExtensionAttachments(AreaTreeHandler.java:213)
        at
org.apache.fop.area.AreaTreeHandler.startAbstractPageSequence(AreaTreeHandler.java:205)
        at
org.apache.fop.area.AreaTreeHandler.startPageSequence(AreaTreeHandler.java:194)
        at
org.apache.fop.fo.pagination.PageSequence.startOfNode(PageSequence.java:114)
        at org.apache.fop.fo.FOTreeBuilder
$MainFOHandler.startElement(FOTreeBuilder.java:295)
        ... 23 more
---------
org.xml.sax.SAXException: Value must not be empty
java.lang.IllegalArgumentException: Value must not be empty
        at org.apache.fop.fo.FOTreeBuilder
$MainFOHandler.startElement(FOTreeBuilder.java:297)
        at
org.apache.fop.fo.FOTreeBuilder.startElement(FOTreeBuilder.java:163)
        at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.closeStartTag(ToXMLSAXHandler.java:208)
        at
com.sun.org.apache.xml.internal.serializer.ToSAXHandler.flushPending(ToSAXHandler.java:281)
        at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.startElement(ToXMLSAXHandler.java:650)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:504)
        at
com.sun.org.apache.xerces.internal.xinclude.XIncludeHandler.startElement(XIncludeHandler.java:911)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(XMLNSDocumentScannerImpl.java:376)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl
$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2732)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:625)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:116)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:488)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:812)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:741)
        at
com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:123)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1208)
        at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl
$JAXPSAXParser.parse(SAXParserImpl.java:525)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transformIdentity(TransformerImpl.java:640)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:711)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:317)
        at
org.apache.fop.cli.InputHandler.transformTo(InputHandler.java:214)
        at
org.apache.fop.cli.InputHandler.renderTo(InputHandler.java:125)
        at org.apache.fop.cli.Main.startFOP(Main.java:166)
        at org.apache.fop.cli.Main.main(Main.java:196)
Caused by: java.lang.IllegalArgumentException: Value must not be empty
        at
org.apache.xmlgraphics.xmp.XMPSchemaAdapter.addStringToArray(XMPSchemaAdapter.java:79)
        at
org.apache.xmlgraphics.xmp.XMPSchemaAdapter.addStringToSeq(XMPSchemaAdapter.java:142)
        at
org.apache.xmlgraphics.xmp.schemas.DublinCoreAdapter.addCreator(DublinCoreAdapter.java:106)
        at
org.apache.fop.pdf.PDFMetadata.createXMPFromPDFDocument(PDFMetadata.java:140)
        at
org.apache.fop.render.pdf.PDFRenderer.renderXMPMetadata(PDFRenderer.java:618)
        at
org.apache.fop.render.pdf.PDFRenderer.processOffDocumentItem(PDFRenderer.java:557)
        at
org.apache.fop.area.RenderPagesModel.handleOffDocumentItem(RenderPagesModel.java:207)
        at
org.apache.fop.area.AreaTreeHandler.addOffDocumentItem(AreaTreeHandler.java:338)
        at
org.apache.fop.area.AreaTreeHandler.wrapAndAddExtensionAttachments(AreaTreeHandler.java:213)
        at
org.apache.fop.area.AreaTreeHandler.startAbstractPageSequence(AreaTreeHandler.java:205)
        at
org.apache.fop.area.AreaTreeHandler.startPageSequence(AreaTreeHandler.java:194)
        at
org.apache.fop.fo.pagination.PageSequence.startOfNode(PageSequence.java:114)
        at org.apache.fop.fo.FOTreeBuilder
$MainFOHandler.startElement(FOTreeBuilder.java:295)
        ... 23 more
---------
java.lang.IllegalArgumentException: Value must not be empty
        at
org.apache.xmlgraphics.xmp.XMPSchemaAdapter.addStringToArray(XMPSchemaAdapter.java:79)
        at
org.apache.xmlgraphics.xmp.XMPSchemaAdapter.addStringToSeq(XMPSchemaAdapter.java:142)
        at
org.apache.xmlgraphics.xmp.schemas.DublinCoreAdapter.addCreator(DublinCoreAdapter.java:106)
        at
org.apache.fop.pdf.PDFMetadata.createXMPFromPDFDocument(PDFMetadata.java:140)
        at
org.apache.fop.render.pdf.PDFRenderer.renderXMPMetadata(PDFRenderer.java:618)
        at
org.apache.fop.render.pdf.PDFRenderer.processOffDocumentItem(PDFRenderer.java:557)
        at
org.apache.fop.area.RenderPagesModel.handleOffDocumentItem(RenderPagesModel.java:207)
        at
org.apache.fop.area.AreaTreeHandler.addOffDocumentItem(AreaTreeHandler.java:338)
        at
org.apache.fop.area.AreaTreeHandler.wrapAndAddExtensionAttachments(AreaTreeHandler.java:213)
        at
org.apache.fop.area.AreaTreeHandler.startAbstractPageSequence(AreaTreeHandler.java:205)
        at
org.apache.fop.area.AreaTreeHandler.startPageSequence(AreaTreeHandler.java:194)
        at
org.apache.fop.fo.pagination.PageSequence.startOfNode(PageSequence.java:114)
        at org.apache.fop.fo.FOTreeBuilder
$MainFOHandler.startElement(FOTreeBuilder.java:295)
        at
org.apache.fop.fo.FOTreeBuilder.startElement(FOTreeBuilder.java:163)
        at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.closeStartTag(ToXMLSAXHandler.java:208)
        at
com.sun.org.apache.xml.internal.serializer.ToSAXHandler.flushPending(ToSAXHandler.java:281)
        at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.startElement(ToXMLSAXHandler.java:650)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:504)
        at
com.sun.org.apache.xerces.internal.xinclude.XIncludeHandler.startElement(XIncludeHandler.java:911)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(XMLNSDocumentScannerImpl.java:376)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl
$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2732)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:625)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:116)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:488)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:812)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:741)
        at
com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:123)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1208)
        at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl
$JAXPSAXParser.parse(SAXParserImpl.java:525)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transformIdentity(TransformerImpl.java:640)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:711)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:317)
        at
org.apache.fop.cli.InputHandler.transformTo(InputHandler.java:214)
        at
org.apache.fop.cli.InputHandler.renderTo(InputHandler.java:125)
        at org.apache.fop.cli.Main.startFOP(Main.java:166)
        at org.apache.fop.cli.Main.main(Main.java:196)
        Finished pdf


Expected results:
pdf should be created.

Additional info:
I googled around before reporting and could not find this exception but similar ones are caused by problems with the fop being intolerant of java versions.  Could that be the problem here?

Comment 1 Anica 2011-03-01 22:57:36 UTC
Further info about java.  Is this all ok?


[anica@localhost Desktop]$ alternatives --config java

There are 2 programs which provide 'java'.

  Selection    Command
-----------------------------------------------
   1           /usr/lib/jvm/jre-1.5.0-gcj/bin/java
*+ 2           /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/bin/java




[anica@localhost Desktop]$ alternatives --config javac

There is 1 program that provides 'javac'.

  Selection    Command
-----------------------------------------------
*+ 1           /usr/lib/jvm/java-1.6.0-openjdk.x86_64/bin/javac

Comment 2 Ruediger Landmann 2011-03-04 04:30:35 UTC
Thanks Anica -- your Java configuration looks fine. 

We haven't tested Publican on F15 yet -- I'll see if I can replicate what you're seeing and report back.

Cheers
Rudi

Comment 3 David Le Sage 2011-03-07 05:54:20 UTC
Rudi,


Just saw this.  I am playing around with Fedora 15 on one of my machines and I had what I *think* is the same error when I was playing with Publican the other night - would have to check again to see if it is the same exception.  


In my case, it was only happening to two of the three books I had on my home machine.  It was quick to trace as it was due to a line missing from the book_info.xml file.

This was missing:

<textobject><phrase>Logo</phrase></textobject>


Here is the full context of that piece of XML:

 <inlinemediaobject>
        <imageobject>
          <imagedata fileref="Common_Content/images/title_logo.svg" format="SVG" />
        </imageobject>
	<textobject><phrase>Logo</phrase></textobject>
      </inlinemediaobject>


Hope this is of some help.

Comment 4 David Le Sage 2011-03-07 09:43:10 UTC
I have just re-tested it.  Yes, it is the same exception, caused when that line of code is excluded from the book_info.xml file.

Comment 5 Ruediger Landmann 2011-03-07 22:44:30 UTC
Thanks David for finding this; Anica, does this solve the problem for you?

Comment 6 Anica 2011-03-08 03:16:57 UTC
Yes, that solves the problem. Thank you so very much.

Comment 7 John J. McDonough 2011-03-25 15:01:09 UTC
I am seeing what might be slightly different, on the 3/21 nightly KDE build:

SEVERE: Exception
java.util.MissingResourceException: File event-model.xml not found
        at org.apache.fop.events.DefaultEventBroadcaster.loadModel(DefaultEventB

Comment 8 John J. McDonough 2011-03-25 17:39:48 UTC
More data.  The same source, same version of publican (2.5) builds correctly on F14.  There is a message:

SEVERE: Couldn't find hyphenation pattern en
Mar 25, 2011 11:18:37 AM org.apache.fop.fonts.FontInfo notifyFontReplacement

but the document builds properly. In both cases publican-fedora 2.0 is the brand

In both cases the source is commit
4b8f68d9604b7225c738d505e7def41079301810
of the release notes

Comment 9 Ruediger Landmann 2011-03-27 22:50:05 UTC
(In reply to comment #8)
> More data.  The same source, same version of publican (2.5) builds correctly on
> F14.  There is a message:
> 
> SEVERE: Couldn't find hyphenation pattern en
> Mar 25, 2011 11:18:37 AM org.apache.fop.fonts.FontInfo notifyFontReplacement
> 
> but the document builds properly. In both cases publican-fedora 2.0 is the
> brand
> 
> In both cases the source is commit
> 4b8f68d9604b7225c738d505e7def41079301810
> of the release notes

Can you confirm the version of FOP please?

Comment 10 John J. McDonough 2011-03-29 14:41:53 UTC
It is the default KDE build from 3/21 ... fop-1.0-14.fc15

Comment 11 Ruediger Landmann 2011-03-29 22:43:44 UTC
This is a separate issue. Publican's pdf.xsl has not been tested yet with FOP 1.0 and we're expecting trouble. 

FOP 1.0 is only in the F15 testing repos right now, so shouldn't be in the GA release. 

Can you please open a separate bug for this problem? We need to make sure we catch these before FOP 1.0 goes live!

Thanks :)
Rudi

Comment 12 Stefan Seefeld 2011-06-30 00:39:58 UTC
What is the state of the fop 1.0 Fedora package ? Fedora 15 doesn't have a working fop, which is quite a shame.

Comment 13 Fedora Update System 2011-09-07 06:56:24 UTC
fop-1.0-17.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/fop-1.0-17.fc15

Comment 14 Fedora Update System 2011-09-08 06:58:28 UTC
Package fop-1.0-17.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fop-1.0-17.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/fop-1.0-17.fc15
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2011-09-25 03:30:20 UTC
fop-1.0-17.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.