Bug 68136 - The gnome menus are totally overloaded and take ages to load the small app icons
The gnome menus are totally overloaded and take ages to load the small app icons
Status: CLOSED DEFERRED
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-desktop (Show other bugs)
limbo
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-06 16:08 EDT by Bernd Bartmann
Modified: 2014-01-21 17:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-06 17:08:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2002-07-06 16:08:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
There are way to many apps in the gnome menus on my system it takes ages to
until all the small app icons are loaded. I propose to use more sub-menus. Even
on my 1280x1024 desktop I can't see all menu entries under "System tools" with
scolling through the menu.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open the gnome menus, e.g. "System tools"
2.
3.
	

Additional info:
Comment 1 Seth Vidal 2002-07-06 16:57:44 EDT
In addition the menus seem to be randomnly organized.

specifically - evolution is under "other" with gnumeric.

and EACH of the screensavers is listed under "other"

finding ximian-evolution in the other menu on a 1024x768 laptop was not obvious
(considering I was looking for evolution :)


Comment 2 Seth Vidal 2002-07-06 17:08:29 EDT
ok I looked a little deeper on this - its just that the .desktop files don't
contain the Categories= key.

I presume this has to be fixed on an app-by-app basis.

Are there plans, however, to reduce the number of items and to make more
consistent the naming scheme and capitalization of the menu items?

for example: under Sound & Video we have:
kmix
volume control
KsCD
CD Player
GTV MPEG Player (with no icon - kinda disconcerting)
The number of duplicates in systems tools is too many to mention - ie:

should I use Printer Configuration, printing mananger or print manager to
control/setup printers?

And is Service Configuration better than SysV-Init editor?

You can understand the confusion - maybe it would be better if all the
redhat-config-* programs shared the same icon/style of icon or something - so I
could at least know which ones those were.

thanks
Comment 3 Havoc Pennington 2002-07-06 18:19:59 EDT
Menus need cleaning up, yes. It's a work in progress.

I'm going to close this bug since it doesn't cover any specific aspect of the
cleanup, and there are hundreds of aspects.

Note You need to log in before you can comment on or make changes to this bug.