Bug 681408 - Applications Fail to Load Templates or Documents; Use All of the CPU's Resources
Summary: Applications Fail to Load Templates or Documents; Use All of the CPU's Resources
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: koffice
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 681411 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-02 02:58 UTC by David Le Sage
Modified: 2012-08-07 19:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-07 19:45:45 UTC


Attachments (Terms of Use)

Description David Le Sage 2011-03-02 02:58:22 UTC
Description of problem:
If I launch a KOffice application like KWord or KSpread and choose "Use this template" from the opening screen, the template will fail to load and the application will start to use all of the CPU's resources.

Version-Release number of selected component (if applicable):
koffice-suite-2.3.2-3.fc15.x86_64


How reproducible:
Every time.

Steps to Reproduce:
1. yum install koffice-suite
2. Launch kspread or kword from within KDE.
3. Click "Use this template" to load default template.
  
Actual results:
According to top, the application uses 99.9% of CPU. The application does not load and must be killed manually.

Expected results:
Template should load.

Additional info:

Comment 1 David Le Sage 2011-03-02 03:01:19 UTC
Also happens if I try to open an existing document.  The file selector appears but when I click on the file, the application starts to hammer the CPU again.:-(

Comment 2 Rex Dieter 2011-03-02 20:32:48 UTC
Odd, are you absolutely certain you have 2.3.2-3 and not a prior 2.3.2 version?  -3 included a patch that fixes the problem(s) you describe.

Comment 3 David Le Sage 2011-03-02 21:53:02 UTC
Yes, definitely:

rpm -qi koffice-suite
Name        : koffice-suite
Epoch       : 3
Version     : 2.3.2
Release     : 3.fc15
Architecture: x86_64
Install Date: Wed 02 Mar 2011 12:51:27 PM EST
Group       : Applications/Productivity
Size        : 0
License     : GPLv2+
Signature   : RSA/SHA256, Wed 23 Feb 2011 06:23:55 AM EST, Key ID b4ebf579069c8460
Source RPM  : koffice-2.3.2-3.fc15.src.rpm
Build Date  : Wed 23 Feb 2011 12:16:55 AM EST
Build Host  : x86-11.phx2.fedoraproject.org
Relocations : (not relocatable)
Packager    : Fedora Project
Vendor      : Fedora Project
URL         : http://www.koffice.org/
Summary     : An integrated office suite
Description :
KOffice is an integrated office suite.

Comment 4 Rex Dieter 2011-03-04 16:35:05 UTC
*** Bug 681411 has been marked as a duplicate of this bug. ***

Comment 5 Rex Dieter 2011-03-04 16:36:02 UTC
Mind trying out this new koffic-2.3.3-1 build?
http://koji.fedoraproject.org/koji/buildinfo?buildID=232030

Comment 6 David Le Sage 2011-03-06 23:20:11 UTC
Hello Rex,

I am happy to test it but what is the easiest way to install it?  I tried to grab it via yum but it wasn't available:

su -c 'yum --enablerepo=updates-testing update koffice-suite'

Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Update Process
No Packages marked for Update


I also tried to download and install all of the individual RPMs but ran into dependency issues.

Comment 7 Fedora Update System 2011-03-07 15:10:43 UTC
koffice-2.3.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/koffice-2.3.3-1.fc15

Comment 8 Fedora Update System 2011-03-08 02:24:40 UTC
koffice-2.3.3-1.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update koffice'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/koffice-2.3.3-1.fc15

Comment 9 David Le Sage 2011-03-08 04:31:25 UTC
Rex,

I just installed koffice-suite-2.3.3-1.fc15.x86_64 via yum and, unfortunately, the problem is still there.

David

Comment 10 Rex Dieter 2011-03-24 11:50:06 UTC
I cannot reproduce this on my f15/x86_64 box, *except* for krita, but I think I'd rather track that one specifically in bug #689126

Comment 11 Fedora End Of Life 2012-08-07 19:45:47 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.