Bug 681626 - User properties seem to parse IP-notated email addresses incorrectly.
User properties seem to parse IP-notated email addresses incorrectly.
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.B02
Unspecified Unspecified
medium Severity unspecified (vote)
: ---
: ---
Assigned To: Ian Springer
Corey Welton
:
Depends On:
Blocks: rhq4 gwt-admin-usersroles
  Show dependency treegraph
 
Reported: 2011-03-02 13:57 EST by Corey Welton
Modified: 2013-08-05 20:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 21:11:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2011-03-02 13:57:54 EST
Description of problem:
I'm not sure exactly what the problem is here, but I think attempting to use a standard dot-notated server IP address as an email address fails if one of the quartets is a single digit.  hacking it with additional zeroes seems to be a work around. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Login as rhqadmin or another user with admin rights.
2.  Administration > Users > rhqadmin
3.  Attempt to edit the email address field, using the string "rhqadmin@127.0.0.1"
4. Noting the result above, attempt to edit the email address field, using the string "rhqadmin@127.0.0.01"

  
Actual results:
The first result fails.  The second works but is sub-optimal.  It appears that any single digit integer used (excepting zero) fails w/o padding the quartet with extra zeroes.

Expected results:
Valid IP notation can be used as part of an email address.

Additional info:
Comment 1 Ian Springer 2011-03-09 16:30:47 EST
This should be fixed by the new email-address validation regexp introduced by [master 4c250b2].
Comment 2 Corey Welton 2011-03-10 08:48:09 EST
Verified
Comment 3 Corey Welton 2011-05-23 21:11:32 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 4 Corey Welton 2011-05-23 21:11:32 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.