Bug 681635 - Entering multibyte characters as a username results in a vertically displayed name, messed up UI, upon login
Entering multibyte characters as a username results in a vertically displayed...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.B02
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Charles Crouch
Mike Foley
:
Depends On:
Blocks: gwt-admin-usersroles
  Show dependency treegraph
 
Reported: 2011-03-02 14:28 EST by Corey Welton
Modified: 2015-02-01 18:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-26 17:27:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot (38.95 KB, image/png)
2011-03-02 14:31 EST, Corey Welton
no flags Details

  None (edit)
Description Corey Welton 2011-03-02 14:28:43 EST
Description of problem:
We can create users with multibyte characters just fine, and these users can login.  However, when they are logged in, the characters are displayed vertically in the headers, instead of horizontally.  This results in a warped UI

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Admin > Users > New
2.  Create a user with a  login of "我很喜欢吃水煮鱼"
3.  Logout; attempt to login as user "我很喜欢吃水煮鱼"
  
Actual results:
The login name is displayed in a vertical column on the right-hand side of the page. This ends up warping the header UI components.

Expected results:
Need to display these vertically.

Additional info:

See forthcoming screenshot
Comment 1 Corey Welton 2011-03-02 14:31:28 EST
Created attachment 481932 [details]
screenshot
Comment 2 Ian Springer 2011-03-09 16:24:17 EST
Do we definitely want to support multi-byte character usernames? Because, if not, the fix here would be to change the user creation form to only permit ASCII characters in usernames. Assigning to Charles so he can comment.

Note You need to log in before you can comment on or make changes to this bug.