Bug 681653 - RFE: Disabled accounts should indicate that acct is disabled vs "wrong user/passwd"
RFE: Disabled accounts should indicate that acct is disabled vs "wrong user/p...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.B02
Unspecified Unspecified
medium Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
: FutureFeature, Improvement
Depends On:
Blocks: gwt-admin-usersroles
  Show dependency treegraph
 
Reported: 2011-03-02 15:32 EST by Corey Welton
Modified: 2013-02-26 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-26 17:28:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2011-03-02 15:32:09 EST
Description of problem:
When attempting to login with a disabled account, the user is given a boilerplate "The username or password provided does not match our records."  We should probably have a different message for such a scenario

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Administration > User > $someaccount
2. Disable said account
3. Attempt to login with said account
  
Actual results:

"The username or password provided does not match our records."

Expected results:
Would be nice to have something like:
"This account has been disabled.  Please contact your system administrator."

Additional info:
Comment 1 Ian Springer 2011-03-09 14:52:35 EST
We definitely don't need this for RHQ4, and I think it's fairly low priority for JON3, especially considering it will be a bit involved to implement. I think the required changes would be something like the following:

1) in AuthenticateUserAction.execute() (portal-war), in the catch Exception block for the call to subjectManager.login(), check if the exception message contains "disabled", and if so, set a request attribute to flag that the login failed because the user was disabled.
2) at the top of Login.jsp (portal-war), either set the response code to something other than 401 (e.g. 403) or set a customer HTTP header (e.g. RHQ-Authentication-Failure-Reason: user-disabled)
3) in LoginView.login(), in the login request callback, check for the HTTP response code or header set in step 2, and if found, add a "This account has been disabled." error message to the login form.

Making it a blocker of jon3 for now. We can decide whether or not to push it later.
Comment 2 Charles Crouch 2011-09-30 13:47:23 EDT
Pushing out of JON3

Note You need to log in before you can comment on or make changes to this bug.