Bug 68166 - Midnight commander segfaults when trying to copy or move certain files
Midnight commander segfaults when trying to copy or move certain files
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: mc (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-07 06:50 EDT by Oleg Drokin
Modified: 2007-04-18 12:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-16 09:01:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oleg Drokin 2002-07-07 06:50:23 EDT
Midnight commander segfaults when trying to copy certain files using internal
copy or move operations.
The pattern is not yet clear, while I am able to copy files off mounted CD
without problems,
copying e.g. netscape plugins to other place on the same partition segfaults.
Here is the backtrace, and actual core file is available if needed.
# file core.15022 
core.15022: ELF 32-bit LSB core file of 'mc' (signal 11), Intel 80386, version 1
(SYSV), from 'mc'

# gdb `which mc` core.15022
<lots of symbols loaded from libs>#0  0x420a7052 in calc_first () from
/lib/i686/libc.so.6
(gdb) bt
#0  0x420a7052 in calc_first () from /lib/i686/libc.so.6
#1  0x420a719a in calc_next () from /lib/i686/libc.so.6
#2  0x420a700e in analyze_tree () from /lib/i686/libc.so.6
#3  0x420a6fee in analyze_tree () from /lib/i686/libc.so.6
#4  0x420a6f57 in analyze () from /lib/i686/libc.so.6
#5  0x420a6aae in re_compile_internal () from /lib/i686/libc.so.6
#6  0x420b04e6 in re_compile_pattern () from /lib/i686/libc.so.6
#7  0x0808f1af in getch ()
#8  0x0805894e in strcpy ()
#9  0x08080a40 in getch ()
#10 0x0806e837 in strcpy ()
#11 0x08067f44 in strcpy ()
#12 0x08067fff in strcpy ()
#13 0x080681d9 in strcpy ()
#14 0x08068398 in strcpy ()
#15 0x08085bd8 in getch ()
#16 0x08085d9a in getch ()
#17 0x08086880 in getch ()
#18 0x420165c4 in __libc_start_main () from /lib/i686/libc.so.6
Comment 1 Michael Schwendt 2002-07-14 07:00:14 EDT
Confirmed. I cannot seem to copy any files at all in "mc", especially not from
mounted CD.

My test-case is as simple as opening a virtual console (e.g. ALT+F1), starting
mc, going into /etc, selecting /etc/fstab, pressing F5, and pressing RETURN.
Gives a segmentation fault always.


Since I see a possibly screen-oriented segfault also in "jed", and both mc and
jed are linked against libslang-utf8.so.1, maybe that's a common bug.
Comment 2 Havoc Pennington 2002-07-15 00:17:54 EDT
Maybe a UTF-8/slang issue?
Comment 3 Oleg Drokin 2002-07-16 09:01:01 EDT
After I upgraded mc package to mc-4.5.55-9 from rawhide, segfaults disappeared
and everything seems to be working now.
Comment 4 Karsten Hopp 2002-07-17 11:44:33 EDT
quote:'everything seems to be working now'

Note You need to log in before you can comment on or make changes to this bug.