Bug 68168 - Pager cannot display 8 bit characters.
Summary: Pager cannot display 8 bit characters.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: mutt   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-07 11:04 UTC by Olivier Baudron
Modified: 2014-03-17 02:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-20 01:52:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Olivier Baudron 2002-07-07 11:04:30 UTC
I upgraded mutt/slang (and newt/slrn/kudzu for dependencies) from RH7.3 to
rawhide: mutt-1.2.5.1-1 and slang-1.4.5-2.

Now, mutt cannot display any 8 bit character anymore, such as ihj (french
accents). It either displays a '?' or the octal value. The pager is the default
one. I had a deep look through the manual and tested several variables but could
not find a way to fix the problem.

Can someone reproduce this?

Comment 1 Olivier Baudron 2002-07-07 11:06:35 UTC
Bugzilla has also 8 bit problems...
ihj should read \'e \`e and \^e (tex notations).

Comment 2 Bill Nottingham 2002-07-08 06:01:59 UTC
mutt 1.2.5.1 or mutt 1.4?

Comment 3 Olivier Baudron 2002-07-08 10:25:57 UTC
Sorry, you are right. The upgrade that causes the problem is:
mutt-1.2.5.1-1 -> 1.4-4
slang-1.4.5-2 -> 1.4.5-7

Comment 4 Bill Nottingham 2002-07-08 18:27:55 UTC
What locale are you running in?

Comment 5 Olivier Baudron 2002-07-29 16:36:14 UTC
I am in C locale.

Comment 6 Olivier Baudron 2002-08-14 00:43:14 UTC
$ LC_ALL=en_GB mutt  => works
$ LC_ALL=C mutt      => fails

Well...  when a mail says in its header:
    Content-Type: text/plain; charset=ISO-8859-1
the pager should display the body with this charset, even in C locale, no?

Comment 7 Bill Nottingham 2003-03-20 01:52:36 UTC
slang is using the current LC_CTYPE to determine what characters are printable.
If it's set to 'C', other charsets won't be considered printable.


Note You need to log in before you can comment on or make changes to this bug.