Bug 68173 - failure to restore iptables file with multiple --dport lines
failure to restore iptables file with multiple --dport lines
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: iptables (Show other bugs)
7.3
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-07 09:06 EDT by ivan
Modified: 2007-03-26 23:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-17 10:10:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ivan 2002-07-07 09:06:44 EDT
Description of Problem:

When having multiple entries in the iptables config file that use --dport 
(or --destination-port) the iptables "rc" script fails to start. However it 
works fine with 1 entry using --dport (or --destination-port), and it 
works fine manually adding the line using iptables (not the "iptables-restore" 
that the rc script uses).


Version-Release number of selected component (if applicable):
iptables-1.2.5-3 or
iptables-1.2.5-5

How Reproducible:

Every time

Steps to Reproduce:
1. Add multiple entries to /etc/sysconfig/iptables file that have --dport 
   (or --destination-port) entries.
2. start (or restart) iptables (rc script) using "service iptables start"


Actual Results:

Failure to start iptables service.


Expected Results:

Start iptables service.


Additional Information:
	
I hand-edit the /etc/sysconfig/iptables file (to be able to add comments, etc), 
so this may have some effect. If the new line is commented out then it all 
works again. I have not gotten round to trying iptables 1.2.6 (from source) 
yet :(
Comment 1 Harald Hoyer 2002-08-12 10:13:35 EDT
please attach /etc/sysconfig/iptables
Comment 2 Michael Schwendt 2002-11-28 09:21:55 EST
Reporter still alive?

Unable to reproduce this. Example needed.

[Earlier versions of iptables had a case where -m tcp was necessary in order to
load the "match TCP" userspace extension module.]

Note You need to log in before you can comment on or make changes to this bug.