Bug 681753 - (CVE-2011-1138) CVE-2011-1138 Wireshark: Off-by-one error in the dissect_6lowpan_iphc function causes application crash (Denial Of Service)
CVE-2011-1138 Wireshark: Off-by-one error in the dissect_6lowpan_iphc functio...
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Product Security
public=20110301,reported=20110301,sou...
: Security
Depends On: 676781
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-03 01:54 EST by Huzaifa S. Sidhpurwala
Modified: 2016-03-04 05:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:50:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Huzaifa S. Sidhpurwala 2011-03-03 01:54:51 EST
Common Vulnerabilities and Exposures assigned an identifier CVE-2011-1138 to
the following vulnerability:

Name: CVE-2011-1138
URL: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-1138
Assigned: 20110302
Reference: CONFIRM:http://anonsvn.wireshark.org/viewvc?view=rev&revision=36036
Reference: CONFIRM:http://www.wireshark.org/docs/relnotes/wireshark-1.4.4.html
Reference: CONFIRM:http://www.wireshark.org/security/wnpa-sec-2011-04.html
Reference: CONFIRM:https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5722

Off-by-one error in the dissect_6lowpan_iphc function in
packet-6lowpan.c in Wireshark 1.4.0 through 1.4.3 on 32-bit platforms
allows remote attackers to cause a denial of service (application
crash) via a malformed 6LoWPAN IPv6 packet.
Comment 1 Huzaifa S. Sidhpurwala 2011-03-03 04:28:36 EST
Created wireshark tracking bugs for this issue

Affects: fedora-all [bug 676781]
Comment 2 Huzaifa S. Sidhpurwala 2011-03-04 01:52:02 EST
The version of wireshark shipped with Red Hat Enterprise Linux 4, 5 and 6 does not have support for IPv6 over IEEE 802.15.4 (aka 6LoWPAN) protocol. Hence is not vulnerable.

This vulnerability does not affect fedora-13 since, it does not have support for IPv6 over IEEE 802.15.4 (aka 6LoWPAN) protocol. 

This vulnerability affects the version of wireshark shipped with fedora-14.

Statement:

Not vulnerable. This issue did not affect the versions of wireshark as
shipped with Red Hat Enterprise Linux 4, 5, or 6.

Note You need to log in before you can comment on or make changes to this bug.