Bug 6818 - Netscape tries to save to file when run as regular user
Netscape tries to save to file when run as regular user
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-08 05:03 EST by eric-redhat
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-28 14:54:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eric-redhat 1999-11-08 05:03:48 EST
Well, not all the time.

If I have netscape already running and then run up2date as
myself (entering the root password), the netscape step will
open up the proper page, but it appears to do it by telling
my already existing copy of netscape (running as "eric"
instead of "root") to open a window.  Therefore when I click
either submit button, I get a save dialog.  This seems to
happen whether I run up2date as "eric" or when I run up2date
as "root" inside of an "eric" X session.

If I exit netscape first, it works fine, since a new copy
running as root is fired up.  If I start up an X session as
root and run it then, up2date works fine.

I tried a workaround of placing this in my own .mailcap:
application/redhat-package-list;/usr/sbin/up2date -p %s

But I just get an error that up2date must be run as root.
(Clearly, simply not having netscape already running is an
easy workaround.  But it seems to me that the mailcap entry
should be more global and that up2date should do something
like ask for the root password when run with the -p option,
instead of simply informing me that it must be run as root.)
Comment 1 Bill Nottingham 1999-11-08 10:54:59 EST
Remove /root/.netscape/lock before running up2date should fix
the problem. It sees the stale lock file from a previous
run of netscape by root, and so tries to send a command to
the currently running netscape.
Comment 2 eric-redhat 1999-11-09 16:59:59 EST
That does temporarily fix the problem.

However, if I run netscape as root and exit normally, there is no lock
file. Consistently, if I run up2date, when it runs netscape, there is
a lock file left behind.

I'd like to suggest 2 things:
1) figure out why the lock file gets erroneously left behind and fix
that
2) Instead of just checking for a lockfile, check for a lockfile, and
if it's found look at the information and determine if it's stale.
Comment 3 Preston Brown 2000-02-28 14:54:59 EST
netscape has been modified for 6.2 to check the lockfile's validity before
trusting it, fixing this problem.

Note You need to log in before you can comment on or make changes to this bug.