Bug 681810 - Input does not work correctly in some common applications like QQ
Summary: Input does not work correctly in some common applications like QQ
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora Localization
Classification: Fedora
Component: Chinese Simplified [zh_CN]
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: TianShixiong
QA Contact: TianShixiong
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-03 10:54 UTC by Tao Wu
Modified: 2014-10-28 23:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-03 14:37:37 UTC


Attachments (Terms of Use)

Description Tao Wu 2011-03-03 10:54:05 UTC
Description of problem:
Input does not work correctly for pinyin input-method in Chinese popular IM software QQ.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Download the installation package of QQ
2.Install and run QQ
3.Switch the input method into pinyin
4.Type some characters
  
Actual results:
Output the English characters 

Expected results:
Output the Chinese characters 

Additional info:

Comment 1 Tommy He 2011-03-04 02:12:31 UTC
I assume you're talking about the deprecated QQ for Linux from Tencent.

AFAIK, it was linked to a old gtk2 library, which might not work with the new IBus-1.4 release.
Since it's a closed commercial package, there's little chance for us to attach a patch for re-linking to the new library deployed in Fedora 15.

I haven't touch QQ for Linux for long so I might be wrong on that. Personal recommendation is to switch to WebQQ as a workaround for QQ IM. It's more robust than the discontinued QQ for Linux.

Thanks for reporting.

Comment 2 Tommy He 2011-03-04 06:30:56 UTC
Probably you need to file a bug to the upstream IBus as well:

http://code.google.com/p/ibus/issues/list


Note You need to log in before you can comment on or make changes to this bug.