Bug 681909 - xmlto return non-zero code with lynx on empty file
xmlto return non-zero code with lynx on empty file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xmlto (Show other bugs)
15
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 660819 661036 716129 716171
  Show dependency treegraph
 
Reported: 2011-03-03 10:06 EST by Dan Horák
Modified: 2011-09-24 23:51 EDT (History)
4 users (show)

See Also:
Fixed In Version: xmlto-0.0.24-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-24 23:51:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reproducer (610 bytes, application/octet-stream)
2011-03-03 10:06 EST, Dan Horák
no flags Details
reproducer (438 bytes, application/x-shellscript)
2011-03-03 10:26 EST, Dan Horák
no flags Details

  None (edit)
Description Dan Horák 2011-03-03 10:06:23 EST
Created attachment 482102 [details]
reproducer

xmlto return a non-zero return code when the browser that satisfies the text-www-browser requirement is lynx instead of w3m

reproducable on F14, F15

output with lynx installed:

[dan@eagle libXtst]$ sh xmlto-test.sh 
Test on empty file, fails with lynx, OK with w3m
/home/dan/projects/fedora/zedora/libXtst/test.xml:1: parser error : Document is empty

^
/home/dan/projects/fedora/zedora/libXtst/test.xml:1: parser error : Start tag expected, '<' not found

^
unable to parse /home/dan/projects/fedora/zedora/libXtst/test.xml

Can't Access `file://localhost/tmp/xmlto.tZVo9J/test.proc'
Alert!: Unable to access document.

lynx: Can't access startfile 
return code=1
Test on empty book
return code=0


output with lynx and w3m installed:

[dan@eagle libXtst]$ sh xmlto-test.sh 
Test on empty file, fails with lynx, OK with w3m
/home/dan/projects/fedora/zedora/libXtst/test.xml:1: parser error : Document is empty

^
/home/dan/projects/fedora/zedora/libXtst/test.xml:1: parser error : Start tag expected, '<' not found

^
unable to parse /home/dan/projects/fedora/zedora/libXtst/test.xml
w3m: Can't load /tmp/xmlto.BgOv9F/test.proc.
return code=0
Test on empty book
return code=0
Comment 1 Dan Horák 2011-03-03 10:26:47 EST
Created attachment 482103 [details]
reproducer
Comment 2 Ondrej Vasik 2011-03-03 10:51:13 EST
Adding Kamil to cc, as he is lynx maintainer and only lynx returns 1 on this empty book.
Comment 3 Dan Horák 2011-03-03 10:57:17 EST
and possible new feature - show the command line how the browser is doing the conversion when run with "verbose" option
Comment 4 Ondrej Vasik 2011-03-04 02:42:58 EST
Yep, makes sense, feature from comment #3 was added by https://fedorahosted.org/xmlto/changeset/56/ , thanks for suggestion.
Comment 5 Thomas E. Dickey 2011-05-25 19:18:21 EDT
Looking at the error message, it seems possible that lynx is
being called, told to process a non-existent temporary file.

I don't see the xmlto-test.sh anywhere (and a quick read of
xmlto-0.0.23-4.fc15 doesn't show where/how lynx might be
invoked).
Comment 6 Ondrej Vasik 2011-05-26 01:25:48 EDT
Thanks for comment, lynx is called in txt format helping script (/usr/share/xmlto/format/docbook/txt) ... however it seems you are right here ... well, probably I could ensure that the file exists (even empty) with touch... these temp files are deleted anyway, so it should not cause any troubles...
Comment 7 Ondrej Vasik 2011-05-30 08:03:41 EDT
Yep, touch seems to solve the issue with empty file... https://fedorahosted.org/xmlto/changeset/57/ ... will try to find some time to finish xmlto 0.0.24 in June or July...
Comment 8 Thomas E. Dickey 2011-05-30 10:03:04 EDT
thanks (I seem to recall this issue reported a while back, in a different
report - at the time I had thought the issue was that the file was removed
before lynx could see it).
Comment 9 Ondrej Vasik 2011-08-25 06:02:07 EDT
xmlto-0.0.24 is already finished and in rawhide (and this issue is not present there) - not worth of an update in released fedora, though - so closing RAWHIDE.
Comment 10 Henrik Nordström 2011-09-14 15:13:32 EDT
Can we please have xmlto-0.0.24 pushed as an update for F15? It's the cause to a number of FTBFS issues in other packages. This causes those packages to not be built at all in the ARMv7 secondary arch, in addition to blocking any F15/F16 updates of those packages as well.
Comment 11 Ondrej Vasik 2011-09-15 00:03:10 EDT
OK...
Comment 12 Fedora Update System 2011-09-15 05:26:33 EDT
xmlto-0.0.24-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xmlto-0.0.24-1.fc15
Comment 13 Fedora Update System 2011-09-15 22:01:15 EDT
Package xmlto-0.0.24-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xmlto-0.0.24-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xmlto-0.0.24-1.fc15
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2011-09-24 23:51:46 EDT
xmlto-0.0.24-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.