Bug 68192 - Nmap finds no open ports
Nmap finds no open ports
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: nmap (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-07 18:35 EDT by Daniel Hammer
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-08 14:15:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Hammer 2002-07-07 18:35:14 EDT
Description of problem:
Nmap finds no open port

Version-Release number of selected component (if applicable):
 nmap-2.54BETA34-3
 nmap-frontend-2.54BETA34-3

How reproducible:
Always

Steps to Reproduce:
Start nmapfe (preferable as root) and scan a known host with known 
open ports on it (to verify the result later).


Actual Results:  
For any host, except localhost (127.0.0.1), nmap finds that 
"all 1556 scanned ports on (_chosen_host_) are: filtered" even though 
there are open ports there.

Expected Results:  Nmap should show the open ports
Comment 1 Harald Hoyer 2002-07-08 05:40:09 EDT
I cannot reproduce it with the Limbo Beta... Can you retry it with another host?
nmap-2.54.36-1 is worth another try.
Comment 2 Daniel Hammer 2002-07-08 13:31:07 EDT
I am pretty much sure, that the whole thing is a compiler issue: I've
compiled nmap sources on both, Red Hat 7.3 and "limbo". The whole 
compilation takes a few seconds on RH 7.3 and essentially longer with
a universe of warnings on "limbo" which comes with gcc 3.1.x.
Finally, nmap compiled on RH 7.3 works with all versions of it. On the
other hand, no version of nmap compiled on "limbo" with gcc 3.1.x does
work properly.
In the latter case it finds open (but not filtered) ports on localhost
and a machine on a "private" network (e.g., 192.168.0.x) directly 
connected to the initial box. 
Although "ping" and "traceroute", "dig" etc. and other network services
work fine, nmap does not find any open ports on a machine which is 
somewhere on the internet.
Stracing the whole thing on "limbo" with "-o logbook" gives a lot of 
messages of type:

select(5, [4], NULL, NULL, {0, 20000})  = 0 (Timeout)
gettimeofday({1026139456, 651161}, NULL) = 0

in the logbook where the numbers in the latter line differ from attempt
to attempt.
Comment 3 Nathan G. Grennan 2002-07-08 14:14:59 EDT
(The 1539 ports scanned but not shown below are in state: closed)
Port       State       Service
22/tcp     open        ssh                     
25/tcp     open        smtp                    
53/tcp     open        domain                  
80/tcp     open        http                    
111/tcp    filtered    sunrpc                  
113/tcp    open        auth                    
135/tcp    filtered    loc-srv                 
139/tcp    filtered    netbios-ssn             
443/tcp    open        https                   
445/tcp    filtered    microsoft-ds            
465/tcp    open        smtps                   
651/tcp    open        unknown                 
993/tcp    open        imaps                   
995/tcp    open        pop3s                   
3306/tcp   open        mysql                   
10000/tcp  open        snet-sensor-mgmt        
27374/tcp  filtered    subseven                

Nmap run completed -- 1 IP address (1 host up) scanned in 50 seconds

Works fine for me.
Comment 4 Daniel Hammer 2002-07-09 16:53:52 EDT
Tested the whole thing today again (about five different install sessions on
different machines). It worked fine, what a surprise (!) although for my first 
3-5 install sessions - also on different machines - it didn't work.
Can't figure out what exactly the problem is since all install sessions went
through without errors ... it's like russian roulette ... maybe a dependency
problem of different packages.
'Give up ... sorry for bothering.
Comment 5 Daniel Hammer 2002-07-09 16:55:57 EDT
BTW, what is bug 67218 about ... I "do not have the permissions necessary to 
see bug 67218" ???

Note You need to log in before you can comment on or make changes to this bug.