Bug 68193 - Mouse does not work with xboard
Mouse does not work with xboard
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: xboard (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-07 18:46 EDT by Peter van Egdom
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-08 02:09:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter van Egdom 2002-07-07 18:46:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020625

Description of problem:
When I start "xboard" I cannot use the mouse to move the
chess pieces or go the menu.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start "xboard"
2. Try to move the chess pieces with the mouse.
3.
	

Actual Results:  The chess pieces and the menu don't work with the
mouse.

Expected Results:  I expect to move some chess pieces or manipulate the
menu with the mouse.

Additional info:

[peterve@limbohp peterve]$ rpm -qfi /usr/bin/xboard 
Name        : xboard                       Relocations: (not relocateable)
Version     : 4.2.5                             Vendor: Red Hat, Inc.
Release     : 4                             Build Date: ma 24 jun 2002 03:45:58 CEST
Install date: zo 07 jul 2002 13:20:43 CEST      Build Host: perf90.perf.redhat.com
Group       : Amusements/Games              Source RPM: xboard-4.2.5-4.src.rpm
Size        : 1101328                          License: GPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : An X Window System graphical chessboard.
Comment 1 Karsten Hopp 2002-07-08 05:11:05 EDT
I've tested this with gnuchess-5.02-8 and xboard-4.2.5-4 and can't reproduce it. 
It takes a moment to initialize the game, perhaps even up to a minute pn slower CPUs. 
During that time xboard doesn't react on mouse movements, perhaps that's what you're 
seeing ?
Comment 2 Peter van Egdom 2002-07-08 16:46:02 EDT
Oops, you're right. Sorry for the panicky bug report from me. :-)

(It was probably the impatient little boy in me who filed the bug.)

I run Limbo on 2 machines, a slower Pentium I class machines and
a Pentium III.

On the slow machine it takes up to half a minute before startup.
The faster machine takes up a few seconds.


Note You need to log in before you can comment on or make changes to this bug.