Bug 68206 - Not able to save 'Smart Browsing' preferences
Not able to save 'Smart Browsing' preferences
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-07 22:54 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 05:58:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-07 22:54:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
When I was trying to use the search functionality in the URL address bar, I
found it wasn't working.  After I went into the preferences and enabled
'Location Bar Autocomplete' functionality and returned to the browser, it still
didn't work.  This prompted me to return to the prefernces location again, only
to find out that the boxes I checked previously became unchecked.  I have tried
different combinations of checked/unchecked along with closing the browser
between preference changes, but it still doesn't work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
(as normal non-root user)
1. Load mozilla browser
2. Under Navigator->Smart Browsing->Location Bar Autocomplete, select any
checkboxes.
3. Select OK in the various preference boxes to return to the browser
4. Go the the location specified in step 2.
	

Actual Results:  The boxes that were checked became unchecked.

Expected Results:  The boxes should still be checked.

Additional info:

I've had no problems with this feature in the binary versions of mozilla from
mozilla.org (running as normal user)
Comment 1 Andrew Jones 2002-12-30 14:23:38 EST
Me too! :) My problem is very similar. For me it's under "Mail & Newsgroup
Account Settings", "Copies & Folders". Under "Place a copy in:", which is
checked, i try to click "Sent folder on:" and change the drop down box to "Local
Folders". Similarly i click "Drafts folder on:"+Local Folders and "Templates
folder on:"+Local Folders. These were the settings before upgrading to RedHat
8.0 (i have mails dating back more than two years under Sent, but the last one
was from the middle of October, when i installed 8.0). Anyway, i click OK, and
the settings don't take effect. I can try again and again, but all to no avail.
Also interesting to note, the second check box in the same dialog (between
"Place copy in:" and "Bcc another address") has no text next to it.
I would be happy to attach my prefs.js file, if it would help. Tell me if i can
do anything to assist.
Comment 2 Christopher Aillon 2005-03-31 05:58:48 EST
Works in fc3
Comment 3 Andrew Jones 2005-03-31 22:02:25 EST
That's certainly news to me. I have had FC3 since it came out, and i have tried
setting these options more than once. The problem still exists.
Comment 4 Christopher Aillon 2005-04-01 02:03:12 EST
Sounds like there is something going on then with your install.  I really have
no idea what would be causing that, but I've tried both your preference issues
and the original one on 2 different FC3 boxes (one vanilla fc3, one fc2 upgraded
to fc3+updates) just now and it works fine on both.  rawhide also works fine.

Try with a freshly created profile?  uninstall and reinstall the rpm?
Comment 5 Andrew Jones 2005-04-01 14:24:53 EST
Yeah, i've had the same solution in mind for a long time now, but i haven't
gotten around to it yet. I decided to attach myself to this bug because this
behaviour started right after i installed RH 8. Oh, well. Thanks for the help.
I'll get around to fixing (or better identifying) my problem another time.

Note You need to log in before you can comment on or make changes to this bug.