Bug 682066 - panic on ipv6 udp-fragmentation-offload of bridge device
Summary: panic on ipv6 udp-fragmentation-offload of bridge device
Keywords:
Status: CLOSED DUPLICATE of bug 698170
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Herbert Xu
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-04 02:10 UTC by Masahiro Matsuya
Modified: 2018-11-14 14:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-19 11:50:12 UTC


Attachments (Terms of Use)

Description Masahiro Matsuya 2011-03-04 02:10:41 UTC
Description of problem:
The kernel panic occurs if a bridge device is connected with physical NIC and UDP packets are transmitted via the bridge device.

The kernel panic occurs when all the following conditions consist:
- The kernel version is RHEL6(2.6.32-71.xx.el6).
- The NETIF_F_HW_CSUM of the physical device connected with the bridge device is available.
- The udp-fragmentation-offload function of the bridge device is available(ON).
- The udp-fragmentation-offload function of the physical NIC is unavailable(OFF).
- IPv6 protocol
- The size of the UDP datagram exceeds MTU. (fragmentation is necessary)

The system configuration:
Test_program ---> UDP/IP ---> bridge(br0) ---> NIC(eth0) ---> network

Version-Release number of selected component (if applicable):
kernel-2.6.32-71.el6 

How reproducible:
Always with the reproducer

Steps to Reproduce:
1. gcc -o udp6_send udp6_send.c 
2. run reproducer.sh (put udp6_send in the same directory).
  
Actual results:
Kernel Panic occurs.

Expected results:
Kernel Panic doesn't occur.

Additional info:

Comment 12 Herbert Xu 2011-09-19 11:50:12 UTC

*** This bug has been marked as a duplicate of bug 698170 ***


Note You need to log in before you can comment on or make changes to this bug.