Bug 68207 - No sound in 2.4.18-5 kernel
Summary: No sound in 2.4.18-5 kernel
Status: CLOSED DUPLICATE of bug 54905
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-08 03:37 UTC by Need Real Name
Modified: 2013-07-03 02:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-09 12:44:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-07-08 03:37:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
When I log in I get the follwing x dialog box.
Sound server Informational message:
Error while installing the sound driver
device /dev/dsp can't be opened (No such device)
The sound server will continue, using the null output device.

When I run sound config it detects my card o.k. 

                      A PCI sound card was found in your   ?
                    ? system. The details are:             ?
                    ?                                      ?
                    ?      Model: VIA Technologies|VT8233  ?
                    ? AC97 Audio Controller                ?
                    ?

but when I try to play the sound sample, I get this...

        ??????????????????????? modprobe error ????????????????????????
        ?                                                             ?
        ? The following error occurred running the modprobe program:  ?
        ?                                                             ?
        ? /lib/modules/2.4.18-5/kernel/drivers/sound/via82cxxx_audio  ?
        ? .o: init_module: No such device                             ?
        ? /lib/modules/2.4.18-5/kernel/drivers/sound/via82cxxx_audio  ?
        ? .o: insmod                                                  ?
        ? /lib/modules/2.4.18-5/kernel/drivers/sound/via82cxxx_audio  ?
        ? .o failed                                                   ?
        ? /lib/modules/2.4.18-5/kernel/drivers/sound/via82cxxx_audio  ?
        ? .o: insmod sound-slot-0 failed                              ?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select the 2.4.18-5 kernel from the grub boot menu
2. log in as a normal (not super user) user

	

Additional info:

The system did not exhibit this behavior under 2.4.18-3 & -4.

Comment 1 Torsten Schuetze 2002-07-18 06:39:12 UTC
Same problem here, sound is broken in 2.4.18-5,
/proc/pci says:
Bus  0, device  17, function  5:
    Multimedia audio controller: VIA Technologies, Inc. VT8233 AC97 Audio
Controller (rev 16).
      IRQ 5.
      I/O at 0x1000 [0x10ff].

I get the same error messages, even when I recompile the kernel.

Comment 2 Paul Gear 2002-10-05 10:36:26 UTC
This sounds like another duplicate of 54905.  It is still broken in 8.0.

Comment 3 Jeff Garzik 2002-10-09 14:38:55 UTC

*** This bug has been marked as a duplicate of 54905 ***


Note You need to log in before you can comment on or make changes to this bug.