Bug 68211 - anaconda Japanese font size varying in places
anaconda Japanese font size varying in places
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
Depends On:
Blocks: 67217
  Show dependency treegraph
Reported: 2002-07-08 01:18 EDT by Jens Petersen
Modified: 2007-04-18 12:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-09-03 07:50:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2002-07-08 01:18:59 EDT
Description of Problem:
Some single Japanese kanji characters in the text of the installer
are a different size to the rest.  This looks very akward.

Version-Release number of selected component (if applicable):

How Reproducible:
every time

Steps to Reproduce:
1. do install in Japanese
2. go to the mouse configuration page for example

Actual Results:
The two kanji (Chinese) charcters [5th and 6th characters] of
the title, and the first kanji of the text to the right of the
mouse icon are noticeably smaller than the rest of the text 
(including other kanji characters).

Expected Results:
All the kanji chars should be displayed the same size.

Additional Information:
This problem problem has been occurring for a while with gtk2
Comment 1 Leon Ho 2002-07-15 21:02:40 EDT
Jeremy is trying to use Xft instead of pango with X font system now. We will only need to 
manage one font conf file as well as fixes couple bugs in anaconda if that's possible.
Comment 2 Jeremy Katz 2002-07-18 02:08:43 EDT
Switched to Xft in CVS; should hopefully fix these problems
Comment 3 Akira TAGOH 2002-07-26 10:47:46 EDT
font size looks good. but Japanese glyphs and Chinese glyphs are still mixed.
obvious difference is the punctuation mark. In Japanese, those glyphs is
rendered with low baseline. and in Traditional Chinese, it's rendered with
middle baseline. and in Simplified Chinese, it's rendered in between Japanese
and Traditional Chinese.
Also in Korean, it's rendered with top baseline.
Looks like current anaconda is choosing some glyphs for Traditional Chinese when
I install with Japanese.

BTW I tried this on Limbo-re0725.2.
Comment 4 Akira TAGOH 2002-07-30 04:43:34 EDT
I've tested the anaconda on X (I mean runs /usr/sbin/anaconda on the terminal).
when I ran it with LANG=ja_JP.eucJP and chose 'Japanese' for the language
selection, it works fine. but when I ran it with LANG=C and chose 'Japanese',
this problem appeared.
Is this the Pango issue? or does the laugnage selection's code have a bug?
Comment 5 Leon Ho 2002-07-31 00:00:07 EDT
I am not sure if anaconda uses serif. If it is, then it missing one of the ttf font in 
installation environment.
Comment 6 Akira TAGOH 2002-07-31 03:05:52 EDT
I don't think that's related this problem. because, as I said, I also saw this
problem on the environment already installed.
Comment 7 Leon Ho 2002-07-31 20:00:18 EDT
But anaconda does set the LANG environment.  
Also if you run LANG=C in pango, then it won't append any CJK font in the font list, 
therefore it will only use the default font alias list. 
Now the only different between anaconda installation env and installed env is the font we 
are missing, so that is my take on this problem. 
Comment 8 Akira TAGOH 2002-08-12 05:05:53 EDT
Hmm, if a current locale matches nothing on <match> tag, looks like Pango (or
fontconfig?) decides some glyphs from the last entry's font. for example, as I
said, when I ran anaconda with LANG=C, this problem appears. then when I move
<match> tag for Japanese to the end of <match> tag in fonts.conf, anaconda works
fine with LANG=C. if Pango or fontconfig can be clear something like the cache
for font, or if anaconda can re-creates an instance for font, maybe this problem
may be solved.
Owen, how do you think about it?
Comment 9 Owen Taylor 2002-08-13 22:47:44 EDT
Basically, Pango wasn't doing anything for language tags with Xft,
font ordering was based on the locale when a font description
was first loaded.

I believe pango-1.1.0-3 should fix this problem; it would be good
to test it to make sure it fixes the anaconda problem.
Comment 10 Jens Petersen 2002-08-15 02:09:53 EDT
This problem looks ok to me now; though I really don't like the mixture
of ttf and bitmap rendering for Japanese at least: it looks quite akward
to me anyway.  For Japanese I think we should either use all bitmap or all
ttf rendering not the current compromise.  Any other opinions?
Comment 11 Owen Taylor 2002-08-15 09:30:50 EDT
I think the mixed rendering now is just that some widgets aren't
being recreated so they are keeping their old fonts. (Known

Everything should be bitmap, as long as the characters are in the 
'Kochi Gothic' font.
Comment 12 Akira TAGOH 2002-08-15 09:58:23 EDT
Well, about using the embedded bitmap, you mean non-anti-aliased Kochi font is ugly?
Indeed, the Kochi fonts is rengered with the outline only may be ugly. but, if
we can use the anti-aliasing font, it's enough to me more than the embedded
bitmap font.
Comment 13 Akira TAGOH 2002-09-02 02:23:03 EDT
Hmm, this problem appears again in some button on below screen and online-help.
I wonder if the changing on Bug#65913 is affected Japanese.
I can see a problem since Milan-re0829.0. some Japanese glyphs and some Chinese
glyphs are mixed. and bitmap fonts and anti-aliased fonts are also mixed. it's
very ugly.
When I press Hide Help button, then press Show Help button, all glyphs  are
shown correctly on the online-help.
Comment 14 Nakai 2002-09-02 07:58:42 EDT
Japanese glyphs in Chinese fonts are very broken.
We should not use them in Japanese environment.

Severity high is appropriate.
Comment 15 Owen Taylor 2002-09-02 08:47:28 EDT
Is the online help widget being recreated when the language is
Comment 16 Akira TAGOH 2002-09-02 10:09:04 EDT
Probably yes, this problem appears immediately after switching the languages.
'Hide Help', 'Release Notes', 'Back', 'Next' button is also broken all at once.
Comment 17 Jeremy Katz 2002-09-02 12:58:13 EDT
Okay, everything should be completely be getting recreated now on language
switch in CVS and things look right to me.  I'll get an anaconda built and a
tree built so that this can be verified
Comment 18 Akira TAGOH 2002-09-03 07:50:20 EDT
Looks good. I've confirmed it on Milan-re0903.0.
Comment 19 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.