Bug 682114 - yum loaded zh_CN langpack but -en language package of installed application is searched and installed
Summary: yum loaded zh_CN langpack but -en language package of installed application i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-langpacks
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-04 07:55 UTC by He Rui
Modified: 2011-03-19 05:49 UTC (History)
5 users (show)

Fixed In Version: yum-langpacks-0.2.2-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-19 05:49:42 UTC


Attachments (Terms of Use)

Description He Rui 2011-03-04 07:55:33 UTC
Description of problem:
Tried to yum groupinstall office with zh_CN langpack loaded, but -en language packages of office is searched out and installed. It happened both by gtk-application and console. 

Version-Release number of selected component (if applicable):
yum-langpacks-0.1.5-4.fc15.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install F15-alpha
2. change language to zh_CN in /etc/sysconfig/i18n 
3. Logout and relogin to root
4. yum groupinstall office or install office by gtk-application
  
Actual results:
zh_CN langpack is loaded, but -en langpacks of office is searched for installation

Expected results:
-cn(ie Chinese) langpacks of the application is searched and installed

Comment 1 Fedora Update System 2011-03-08 21:44:13 UTC
yum-langpacks-0.2.0-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/yum-langpacks-0.2.0-1.fc15

Comment 2 Fedora Update System 2011-03-11 17:28:31 UTC
yum-langpacks-0.2.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/yum-langpacks-0.2.1-1.fc15

Comment 3 Hedayat Vatankhah 2011-03-13 10:21:23 UTC
I'm using yum-langpacks-0.2.1-1.fc15, but I've this issue which looks like to be related to this problem:
--------------------------------------------------------------------------

[root@localhost /]# echo $LANG
fa_IR.utf8
[root@localhost /]# yum update autoc*
Loaded plugins: langpacks, local, presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package autocorr-en.noarch 0:3.3.1.2-5.fc15 will be updated
---> Package autocorr-en.noarch 0:3.3.1.2-6.fc15 will be an update
---> Package autocorr-fa.noarch 0:3.3.1.2-5.fc15 will be updated
---> Package autocorr-fa.noarch 0:3.3.1.2-6.fc15 will be an update
--> Finished Dependency Resolution
--> Running transaction check
---> Package autocorr-en.noarch 0:3.3.1.2-5.fc15 will be updated
---> Package autocorr-en.noarch 0:3.3.1.2-6.fc15 will be an update
---> Package autocorr-fa.noarch 0:3.3.1.2-5.fc15 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================
 Package           Arch         Version              Repository              Size
==============================================================================
Updating:
 autocorr-en       noarch       3.3.1.2-6.fc15       updates-testing         88 k
Removing:
 autocorr-fa       noarch       3.3.1.2-5.fc15       @updates-testing       1.0 M

Transaction Summary
===============================================================================
Upgrade       1 Package(s)
Remove        1 Package(s)

Total download size: 88 k
Is this ok [y/N]: 
--------------------------------------------------------------------------

Why it tries to remove autocorr-fa?!!

Comment 4 Bill Nottingham 2011-03-14 15:04:27 UTC
Hedayat - that appears to be a new issue. Can you file it as one?

Comment 5 Hedayat Vatankhah 2011-03-14 15:23:18 UTC
OK, done: https://bugzilla.redhat.com/show_bug.cgi?id=684817
Thanks.

Comment 6 Fedora Update System 2011-03-14 18:44:50 UTC
yum-langpacks-0.2.2-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/yum-langpacks-0.2.2-1.fc15

Comment 7 He Rui 2011-03-15 02:59:04 UTC
(In reply to comment #6)
> yum-langpacks-0.2.2-1.fc15 has been submitted as an update for Fedora 15.
> https://admin.fedoraproject.org/updates/yum-langpacks-0.2.2-1.fc15

I tested it by:

#export LC_ALL=zh_CN.UTF-8
#export LANG=zh_CN.UTF-8

Then I tried to 
#yum groupinstall office

I didn't saw the notice 'Add zh_CN to langpack list', is it expected?
Also I saw one '-zh' langpack and 'two' -en langpack were searched out, not sure if it's normal.

Comment 8 Bill Nottingham 2011-03-15 17:55:32 UTC
That is a libreoffice bug; it needs to provide libreoffice-langpack-<langcode>; the plugin is not going to try and encode the knowledge to map Hant -> TC and Hans -> SC. Please file that separately.

Comment 9 Fedora Update System 2011-03-19 05:49:27 UTC
yum-langpacks-0.2.2-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.