Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 682138 - Wrong mouse theme per default.
Wrong mouse theme per default.
Status: CLOSED DUPLICATE of bug 675509
Product: Fedora
Classification: Fedora
Component: LiveCD - Xfce (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
:
Depends On:
Blocks: F15Target-xfce
  Show dependency treegraph
 
Reported: 2011-03-04 04:28 EST by hannes
Modified: 2011-03-04 16:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-04 16:31:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hannes 2011-03-04 04:28:41 EST
The current nightly build uses a very outdated mouse theme. It seems to me like the default mouse theme of the Xserver.
It appears in the 32bit as well as in the 64bit version of this spin.
Don't know how to debug it.
Comment 1 Christoph Wickert 2011-03-04 15:05:24 EST
Here's the problem:
$ rpm -qf /usr/share/icons/default/index.theme
libXcursor-1.1.11-3.fc15.i686
$ cat /usr/share/icons/default/index.theme
[Icon Theme]
Inherits=Adwaita
$ rpm -q --requires libXcursor | grep theme
(nothing)

While on F14 it is:
$ rpm -qf /usr/share/icons/default/index.theme 
libXcursor-1.1.10-5.fc14.i686
$ cat /usr/share/icons/default/index.theme 
[Icon Theme]
Inherits=dmz-aa
$ rpm -q --requires libXcursor | grep theme
dmz-cursor-themes  

Possible solutions:
1. Make libXcursor depend on gnome-themes-standard. If we go that way, the big gnome-themes-package should at least be split up to provide the cursor theme as a separate package.
2. Do it like KDE. They have /usr/share/icons/default.kde4/index.theme provided by and using oxygen-icon-theme. We would need to patch xfce4-settings because it provides /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml 

Advantages of 1:
Consistent cursor everywhere, say in GDM, Xfce and apps that are run as root through userhelper while solution 2 only works when xfce4-settings-helper is running.

Advantages of 2:
No artificial dependencies.
We are in control of the cursor and do not rely on the GNOME folks.

What do you think?
Comment 2 Rex Dieter 2011-03-04 15:09:09 EST
This looks like a dup of bug #675509 essentially
Comment 3 Christoph Wickert 2011-03-04 16:31:47 EST
Yeah, after some conversation on IRC we agreed to discuss everything there.

*** This bug has been marked as a duplicate of bug 675509 ***

Note You need to log in before you can comment on or make changes to this bug.