This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 682156 - regression: anaconda kickstart partitioning scheme used differently
regression: anaconda kickstart partitioning scheme used differently
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.1
Unspecified Unspecified
urgent Severity medium
: rc
: ---
Assigned To: David Lehman
Release Test Team
: Regression
Depends On:
Blocks: RHEL62CCC 846801 846802
  Show dependency treegraph
 
Reported: 2011-03-04 05:28 EST by Stephan Mueller
Modified: 2012-08-08 14:29 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-13.21.106-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 08:38:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephan Mueller 2011-03-04 05:28:02 EST
Description of problem:

The following kickstart partitioning scheme worked on a 10GB hard disk on RHEL6 (note, this is part of a script and the variables are resolved to: FSTYPE==ext4, VGNAME==VolGroup01, ENC==--encrypt or empty):

logvol / --fstype $FSTYPE --name=root --vgname=$VGNAME --size=2048 --grow $ENC
logvol swap --fstype swap --name=LvSwap --vgname=$VGNAME --size=256 --grow --maxsize=512 $ENC
logvol /var/log --fstype $FSTYPE --name=varlog --vgname=$VGNAME --size=200 --grow --maxsize=2048 --fsoptions="defaults,nodev,noexec,nosuid" $ENC

## Optional partitions, you MAY (de)activate and resize as appropriate
logvol /home --fstype $FSTYPE --name=home --vgname=$VGNAME --size=50 --grow --maxsize=10000 --fsoptions="defaults,nodev" $ENC
logvol /var --fstype $FSTYPE --name=var --vgname=$VGNAME --size=500 --grow --maxsize=50000 $ENC
logvol /var/log/audit --fstype $FSTYPE --name=audit --vgname=$VGNAME --size=2000 $ENC
logvol /tmp --fstype $FSTYPE --name=temp --vgname=$VGNAME --size=1000 $ENC


On the RHEL6.1 alpha ISO, the 10GB partition is insufficient - the /tmp partition cannot be created any more. lvm pvdisplay and lvm vgdisplay show a 10GB partition, but lvdisplay shows:

root: 5GB
swap: 384MB
varlog: 288MB
home: 32MB
var: 768MB
audit: 2GB

You see that root is bigger than it need be.


Version-Release number of selected component (if applicable):

RHEL 6.1 alpha ISO
Comment 7 Pavel Holica 2011-03-31 05:08:06 EDT
Reproduced on RHEL6.1 Alpha x86_64 Server, verified fix on RHEL6.1 Beta x86_64 Server.
Comment 8 Stephan Mueller 2011-04-04 09:13:26 EDT
Fix works for me.
Comment 9 errata-xmlrpc 2011-05-19 08:38:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0530.html

Note You need to log in before you can comment on or make changes to this bug.