Bug 68216 - the screen cannot be unlocked
the screen cannot be unlocked
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: xscreensaver (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-08 04:49 EDT by Need Real Name
Modified: 2014-03-16 22:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-15 14:01:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-08 04:49:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; zh-CN; rv:1.0.1) Gecko/20020625

Description of problem:
In the gnome session, I cannot unlock the screen after I've locked it.
I entered the password, but the screensaver neither accept the password,
nor reject it. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install limbo using Simplified Chinese as the default language.
2.lock the screen in Gnome.
3.try to unlock the screen
	

Actual Results:  The screensaver neither accept the password, nor reject it.  
When timeout, the screensaver continues.

Expected Results:  If I enter the right password, the screen is unlocked.

Additional info:

There is some error message when the "enter password" dialog shows,
it says "***parse error *** markup ***"
Comment 1 Need Real Name 2002-07-08 10:33:44 EDT
The system is a clean "limbo" installation.
The versions of the components are:
xscreensaver-4.05-1
libxml2-2.4.22-2
Comment 2 Bill Nottingham 2002-07-08 14:52:04 EDT
Does this happen in non-chinese locales?
Comment 3 Need Real Name 2002-07-08 23:37:00 EDT
That's the point.
When I change the locale from zh_CN.GB18030 to en_US.UTF-8,
then everything is right.The error message I mentioned above disappears too.

By the way, the full error message is
"xscreensaver-lock Gtk-WARNING: failed to set label from markup due to error
parsing markup:****"
Comment 4 Need Real Name 2002-07-11 01:07:14 EDT
But I do want to work under Chinese locale!
I hope this bug can be fixed.
Comment 5 Need Real Name 2002-07-11 01:08:45 EDT
But I do want to work under Chinese locale!
I hope this bug can be fixed.
Comment 6 Jamie Zawinski 2002-07-27 03:20:08 EDT
This probably has something to do with bug 37632, but I don't know what to do
about that one either, so someone who actually understands handling of
non-english keyboards is gonna have to tackle this...

The "failure to set label" error message is almost certainly unrelated to the
password problem.
Comment 7 Need Real Name 2002-08-03 03:05:47 EDT
I've found that the problem is caused by minichinput, which is a XIM based
Chinese input method. If I do "killall chinput" before lock the screen, then I
can unlock the screen without any problem. So, I could unlock the screen under
non-Chinese locale, just because in that locale, chinput did not start.

There is another strange problem in limbo caused by minichinput:
If chinput is running, then one cannot enter "<" in gnome-terminal.

So, I think this bug can be classified as the bug of minichinput, or the
incompatibility between minichinput and xcreensaver, gnome-terminal etc.
Comment 8 Need Real Name 2002-08-03 23:57:39 EDT
Since this problem occurs only in limbo, which uses gnome2.
Maybe this is a incompatibility between chinput and gnome2?

I didn't test other input methods. If other input methods using XIM 
also have this problem, then this is a problem between XIM and gnome2.
Maybe the hackers of GNOME can help us.
Comment 9 Yu Shao 2002-08-09 01:08:30 EDT
When miniChinput is up, and you active xscreensaver, miniChinput as IM server
will receive Input Context(IC) create request and Input Focus request from the
GTK password input entry box, this is correct. But at the same time, miniChinput
also receives a extra Input Context request, but no following Input Focus
request, don't know where this is come from. xscreensaver will reports bad
window error.

And everytime you active the password input entry window from funncy graphics
when saver is on, miniChinput will get all new IC and foucs request, I think
xscreensaver should send re-focus request instead.

Those are the weird things.

Following Owen Taylor's advice, putting following one line in lock-Gtk.c will fix.
        putenv("GTK_IM_MODULE=gtk-im-context-simple); 

I am more believe the bug is in XIM... I will build new xscreensaver package and
do more test.

Comment 10 Yu Shao 2002-08-09 01:53:49 EDT
Please test the latest xscreensaver-4.05-3 and gtk2-2.0.6-2.
Comment 11 Need Real Name 2002-08-15 13:11:40 EDT
The problem no longer exists.I can now unlock the screen.
Thank you!

But the "no < in gnome-terminal" problem still exists.
Comment 12 Owen Taylor 2002-08-15 14:01:36 EDT
I fixed the '<' problem a couple of days ago ... the fix is in gtk2-2.0.6-3 
(not sure if it is in Raw Hide yet.)

Note You need to log in before you can comment on or make changes to this bug.