Bug 68225 - grub doesn't write to mbr
grub doesn't write to mbr
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: grub (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 65956 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-08 06:51 EDT by Marius Andreiana
Modified: 2007-04-18 12:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-31 07:03:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Andreiana 2002-07-08 06:51:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.1 (X11; Linux i586; U;) Gecko/20020417

Description of problem:
after installation (chosed grub and mbr) the system won't boot (invalid boot disk)

Booted with a floppy and ran 
grub-install /dev/hda

everything seemd ok, rebooted but got the same problem.
This system worked with redhat 7.3.

Perhaps I'm doing something wrong, anybody can confirm this?

How reproducible:
Didn't try


Additional info:

I used a harddrive install from iso images on an unused partition
Comment 1 Need Real Name 2002-07-08 12:14:11 EDT
I think the problem I had may be related.  I did a network install using an old
partitioning scheme.  I had 22M at the beginning, then 2 Windows partitions,
250M for swap, 2G partition for /usr1, 3G partion for /home and ~8G for /. 
During installation I got a warning message about /boot being too small, but
decided to try it anyway.  I also specified GRUB as my bootloader (my current
bootloader was LILO).  Once it was installed, I tried to boot it up and got
"LIL-" and no further.  Thinking it was a problem with the /boot partition, I
reinstalled doing an automatic partioning, which left the 22M at the beginning
of the disk free, then my 2 Windows partitions, then my /boot partition, then
swap and /.  Specified GRUB again and had the same problem with the bootloader
after it was done.  Tried one more installation with LILO as my preferred
bootloader and /still/ had the same problem.  Re-installed 7.3 and everything
installed quite nicely.  I hope this helps.
Comment 2 Marius Andreiana 2002-07-08 12:46:00 EDT
another grub bug
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=63367
Comment 3 Mike McLean 2002-07-08 16:08:41 EDT
I just ran a hard drive install from isos and had no problems with grub.  Have
you  been able to reproduce the problem?  Was the earlier comment about
partition sizes possibly the culprit?  

If not, could you provide more information to help me reproduce this bug?
Helpful info might include:
  - the anaconda-ks.cfg left in /root by the installation
  - the output of lspci 
  - any other details you can think of
Comment 4 Need Real Name 2002-07-10 02:13:27 EDT
Very similar scenario took place on my attempts (there were a few) to 
install Limbo using the hard drive option from ISO's onto an Inspiron-8000 
Notebook.
The ISOs resided on /dev/hda5 (fat32)
The install was going onto /dev/hda7 (ext2)
The /dev/hda1, /dev/hda2, /dev/hda5 are fat16, fat32, and swap  respectively.

First,
I attempted to use CD-1 from RH73 to invoke anaconda, then using the expert 
mode continue install from the ISO on /dev/hda5  This process has failed.  
System rebooted unexpectedly after I specified /dev/hda5.

Second,
I used the raw write win to create a boot diskette, and the expert mode.
I used the DISK DRUID to describe partitions (I was unable to map the /dev/hda5 
during this process, as it was used for the install).  
I did the UPGRADE not a clean install.
I chose GRUB to be placed in MBR. 
The whole process went smoothly (including the post install steps), but upon 
reboot, the Laptop froze displaying GRUB-.

Third,
I repeated the Install using the diskette, expert mode, from ISOs on the hard 
drive (/dev/hda5).
This time I chose a clean install.  Again used the DISK DRUID.  Chose GRUB in 
MBR.
Upon reboot the machine froze displaying: GRUB- GRUB- GRUB- GRUB-

Forth,
Repeated the Install using the diskette, expert, hard drive, clean install, 
but this time LILO also in MBR.  Upon reboot the machine froze LIL-

Fifth,
Reinstalled RH73 from the CDs -  NO problems in what so ever

Sixth,
Repeated the install, Identically to step three.  Upon reboot I got GRUB-.
Using the boot up diskette (created during install) I was able to reboot into 
the system.
As root I run the grub-install /dev/hda --  ALL IS WELL NOW

Hope this account of my endeavors will help to make Linux the beautiful thing 
it is!

Arek Kempinski
Arek.K@Juno.com
Comment 5 Jeremy Katz 2002-07-10 14:10:38 EDT
*** Bug 65956 has been marked as a duplicate of this bug. ***
Comment 6 Need Real Name 2002-07-12 01:52:53 EDT
Update:  after my last failed attempt to install limbo w/ working bootloader
last friday, I reinstalled 7.2 on my machine.  I used the partitioning scheme I
had before (22M /boot, 250M swap, 3G /home, 2G /usr1, and ~8G /, plus my 2
windows partitions, not necessarily that order) and chose GRUB as my bootloader.
 Then this morning, after deciding that I /really/ wanted to have a nice,
pretty, working GNOME 2.0 setup and not caring if I had a working bootloader or
not, I gave it another go.  I did a network install, and manually partitioned
/dev/hda.    I removed the 22M /boot partition at the beginning, created a 103M
/boot partition after my windows partition, and left the rest as is.  It
installed without a hitch.  I reboot my machine, and GRUB came up properly and
my limbo partition booted properly!  The first time I had 7.2 on my machine, I
was using LILO as my bootloader.  When I put it back on there last Friday, I put
GRUB on it.  Could this have anything to do with it?   If you would still like
to see my anaconda-ks.cfg left in /root by the installation and the output of
lspci, please let me know. Thanks! -- Brian
Comment 7 Need Real Name 2002-07-12 09:11:04 EDT
ummmm, not that I think it'll make a difference, but my comments before
should've read "after my last failed attempt to install limbo w/ working bootloader
last friday, I reinstalled 7.3" as opposed to 7.2.  So much for coherent thought
at 1:52am....
Comment 8 Jeremy Katz 2002-07-18 23:28:02 EDT
Were these problems with text mode installs?
Comment 9 Marius Andreiana 2002-07-19 02:17:33 EDT
yes
Comment 10 Jeremy Katz 2002-07-19 02:29:30 EDT
Fixed in CVS
Comment 11 Need Real Name 2002-07-19 10:05:50 EDT
yes, I saw the problem when doing a network install in text mode with lilo
previously installed.  When I did the same type of install with grub installed
from my 7.3 installation, all worked well
Comment 12 Bill 2002-07-22 17:23:29 EDT
Text mode install from media checked CDs.  Selected all packages.
Selected grub and mbr.  Made boot floppy.  On Reboot hung at "GRUB _"
prompt.  Booted fine from floppy.  Noticed grub.conf had malformed
kernel line:
"kernel /vmlinuz-2.4.18-5.58 ro root=LABEL=/"
I expected:
"kernel /vmlinuz-2.4.18-5.58 ro root=/dev/hda3"
(quotes here only for clarity, not in the grub.conf...)
repaired grub.conf still failed in same way.

Repeated install except forced LBA-32
same problems.

Then entered grub shell and wrote to mbr.  Fixed Now boots
from hda perfectly.

This is what I did from the grub shell to write (install)
grub on the mbr of the 40GB WD HD /dev/hda:
root (hd0,0)
setup (hd0)
---------- That was it.
Comment 13 Marius Andreiana 2002-07-31 07:03:16 EDT
with limbo2 works for me (didn't work with limbo1)
Comment 14 Mike McLean 2002-07-31 16:52:37 EDT
This was probably that lingering drive sync problem with grub, which is fixed
now.  Since the new beta fixes the reporter's problem I'm closing this bug.
CLOSED->RAWHIDE
Comment 15 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.