This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 68227 - cannot paste with "shift-insert"
cannot paste with "shift-insert"
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: vte (Show other bugs)
limbo
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-08 06:58 EDT by Dams
Modified: 2008-05-01 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-27 21:55:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dams 2002-07-08 06:58:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020625

Description of problem:
I'm not able to paste with the "shift-insert" shortcut with gnome-terminal. All
other terminal (xterm, rxvt, gnome-terminal from gnome1..) have this shortcut..

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. gnome-terminal &
2. select something with the mouse
3. try to paste it with "shift-insert"
	

Actual Results:  the shortcut only print "~".

Expected Results:  The mouse-selection should be pasted.

Additional info:
Comment 1 Havoc Pennington 2002-07-08 15:10:19 EDT
You could always just change the default paste binding to Shift+Insert instead
of Control+Shift+v ...
Comment 2 Daniel Resare 2002-08-22 06:17:13 EDT
The 'edit' -> 'paste' shortcut can not be used, since it is another 'paste' than
the one in rxvt/xterm/gnome-terminal-1. That one works on selections (like an
alias to mouse-button-3) not on the clipboard as the menu item works.

More info over at http://www.jwz.org/doc/x-cut-and-paste.html
Comment 3 Nalin Dahyabhai 2002-08-27 21:57:05 EDT
This should be fixed in vte-0.8.4 and later -- unless bound to another action in
gnome-terminal, Shift+Insert will paste the contents of the PRIMARY clipboard,
the same way that xterm, kterm, and hanterm do.
Comment 4 Owen Taylor 2002-08-28 10:47:01 EDT
Aaargh. Shift-insert is the CUA binding for Paste; if it is 
bound to anything by default, it needs to be bound to 
Paste CLIPBOARD. Making it possible for the user to
bind a "paste primary" in gnome-terminal would be a fine
addition. Binding shift-insert to paste-primary by default
is simply wrong.


Comment 5 Nalin Dahyabhai 2002-08-28 15:10:15 EDT
If we want shift+insert to paste PRIMARY (even by default), it can be overridden
in gnome-terminal's key bindings.
Comment 6 Nalin Dahyabhai 2002-08-28 15:12:49 EDT
Double-aaargh.  I meant "If we want it to paste CLIPBOARD", it can be overridden
at the gnome-terminal level with a keybinding.

Note You need to log in before you can comment on or make changes to this bug.