Bug 68231 - [RFE] old pkg lists and headers pile up in spool dir
[RFE] old pkg lists and headers pile up in spool dir
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-08 08:15 EDT by Michael Schwendt
Modified: 2015-01-07 18:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-17 08:08:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-07-08 08:15:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605

Description of problem:
In up2date's spool directory, old package lists and RPM header files pile up.
The user must clean the directory manually or configure tmpwatch to get rid of
old files periodically.

Although my up2date is configured with "keepAfterInstall=1" to keep the
downloaded rpms, old package lists and rpm header files in the spool directory
should expire automatically after a grace period of, let's say, 7-14 days.

Considering that up2date is supposed to increase automation, the user should not
have to remove unused and out-of-date files in the spool directory manually. The
user's disk space might be huge enough to keep all downloaded packages. But that
is no reason to keep also all old *.hdr files and lots of old package list files.


Version-Release number of selected component (if applicable):
up2date-2.7.86-7.x.3


How reproducible:
Always

Steps to Reproduce:
Configure up2date with "keepAfterInstall=1", let it fetch and apply a series of
packages over some arbitrary period of time, and observe that not only the
downloaded rpms but also old and unused package lists and *.hdr files are kept
and never get deleted automatically.

Additional info:

[Filed against Valhalla because I assume blindly that it applies to Limbo, too.]
Comment 1 Adrian Likins 2002-08-08 22:52:36 EDT
this should be fixed in current versions (2.9.30~ at least...)

Comment 2 Michael Schwendt 2003-03-17 08:08:41 EST
Confirmed with Psyche and Phoebe and package/obsoletes lists.

Old package header (.hdr) files don't get deleted automatically, though, but
they are small and few and hence a lesser problem.

Note You need to log in before you can comment on or make changes to this bug.