Bug 682367 - mii-tool will only iterate over ethX interfaces
mii-tool will only iterate over ethX interfaces
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: net-tools (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 682334 682368
  Show dependency treegraph
 
Reported: 2011-03-04 19:21 EST by Bill Nottingham
Modified: 2014-03-16 23:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: net-tools-1.60-117.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 682368 (view as bug list)
Environment:
Last Closed: 2011-06-15 19:51:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2011-03-04 19:21:20 EST
Description of problem:

Network devices can have arbitrary names, and due to
http://fedoraproject.org/wiki/Features/ConsistentNetworkDeviceNaming, will have
different names in Fedora 15.

mii-tool, if passed no arguments, will only iterate across devices named ethX.

...
    /* No remaining args means show all interfaces. */
    if (optind == argc) {
        ret = 1;
        for (i = 0; i < MAX_ETH; i++) {
            sprintf(s, "eth%d", i);
            ret &= do_one_xcvr(skfd, s, 1);
        }
...
etc.


Version-Release number of selected component (if applicable):

net-tools-1.60

How reproducible:

By inspection.

Additional info:

It does say the program is obsolete. We could just remove it?
Comment 1 Jiri Popelka 2011-03-07 06:42:23 EST
(In reply to comment #0)
> It does say the program is obsolete. We could just remove it?

Well, I like the idea of removing this prehistoric tool too, but
there are still some people using it (e.g. bug #539575).

So I think it would be better to fix it to request the device name as argument (as ethtool does).
Comment 2 Fedora Update System 2011-06-09 05:55:28 EDT
net-tools-1.60-117.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/net-tools-1.60-117.fc15
Comment 3 Fedora Update System 2011-06-11 00:26:49 EDT
Package net-tools-1.60-117.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing net-tools-1.60-117.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/net-tools-1.60-117.fc15
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2011-06-15 19:51:42 EDT
net-tools-1.60-117.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.