Bug 682373 - linux net event code is... bad
linux net event code is... bad
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: papi (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: William Cohen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 682334 682374
  Show dependency treegraph
 
Reported: 2011-03-04 20:27 EST by Bill Nottingham
Modified: 2014-03-16 23:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 682374 (view as bug list)
Environment:
Last Closed: 2011-03-10 16:17:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2011-03-04 20:27:32 EST
Description of problem:

1) It hardcodes devices in the ethX space. Network devices can have arbitrary names, and due to http://fedoraproject.org/wiki/Features/ConsistentNetworkDeviceNaming, will have
different names in Fedora 15.

2) It hardcodes the specific device names, such that it will only read 'lo' and 'eth0-4'. What if you have more than five ethernet devices? What if due to hardware changes, you merely have eth4-7?

3) It does all this by popen()ing ifconfig.

I would think this could be made a lot shorter, simpler, and more correct by just opening and reading /proc/net/dev.

Version-Release number of selected component (if applicable):

papi-4.1.2.1

How reproducible:

By visual inspection.
Comment 1 Bill Nottingham 2011-03-08 11:59:59 EST
Statistics are also in /sys/class/net/<device>/statistics, which is probably even easier to parse.
Comment 2 William Cohen 2011-03-10 14:58:35 EST
PAPI isn't currently being built with any of the PAPI-C components, so this isn't visible in any of the executables in the package.
Comment 3 Bill Nottingham 2011-03-10 15:05:01 EST
Hooray... so this can be closed? Or is the plan to enable these at some point?
Comment 4 William Cohen 2011-03-10 16:17:23 EST
This doesn't yield any problem executables because the PAPI-C components are
not enabled.

Note You need to log in before you can comment on or make changes to this bug.