Bug 682381 - hardcodes eth0
hardcodes eth0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ppp (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 682334
  Show dependency treegraph
 
Reported: 2011-03-04 21:00 EST by Bill Nottingham
Modified: 2014-11-09 17:34 EST (History)
3 users (show)

See Also:
Fixed In Version: ppp-2.4.5-17.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 682382 (view as bug list)
Environment:
Last Closed: 2011-06-21 13:23:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2011-03-04 21:00:01 EST
Description of problem:

Network devices can have arbitrary names, and due to
http://fedoraproject.org/wiki/Features/ConsistentNetworkDeviceNaming, will have
different names in Fedora 15. Also, it's possible due to hardware changes, etc. that a box only has eth1, eth2, etc.

ppp-2.4.5/pppd/sys-linux.c:

...
char *
get_first_ethernet()
{
        return "eth0";
}
...
int
ether_to_eui64(eui64_t *p_eui64)
{
...
    strcpy(ifr.ifr_name, "eth0");
    if(ioctl(skfd, SIOCGIFHWADDR, &ifr) < 0)
    {
        close(skfd);
        warn("could not obtain hardware address for eth0");
...

Now, given that it does have fallback code for both of these functions if it fails, I'm not sure it drastically affects functionality at runtime. Filing for completeness.

Version-Release number of selected component (if applicable):

ppp-2.4.5

How reproducible:

By visual inspection.
Comment 1 Fedora Update System 2011-06-02 02:25:41 EDT
ppp-2.4.5-17.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ppp-2.4.5-17.fc15
Comment 2 Fedora Update System 2011-06-03 01:31:37 EDT
Package ppp-2.4.5-17.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ppp-2.4.5-17.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ppp-2.4.5-17.fc15
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2011-06-21 13:22:59 EDT
ppp-2.4.5-17.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.