Bug 682383 - SELinux is preventing systemd-readahe from 'write' accesses on the directory /var/lib/gdm/.gconf.mandatory.
SELinux is preventing systemd-readahe from 'write' accesses on the directory ...
Status: CLOSED DUPLICATE of bug 669672
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
15
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:c49d0c3ec38...
:
: 682446 682448 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-04 21:25 EST by yunustj
Modified: 2011-03-07 05:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-07 05:17:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yunustj 2011-03-04 21:25:06 EST
SELinux is preventing systemd-readahe from 'write' accesses on the directory /var/lib/gdm/.gconf.mandatory.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that systemd-readahe should be allowed write access on the .gconf.mandatory directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep systemd-readahe /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:readahead_t:s0
Target Context                system_u:object_r:xdm_var_lib_t:s0
Target Objects                /var/lib/gdm/.gconf.mandatory [ dir ]
Source                        systemd-readahe
Source Path                   systemd-readahe
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           gdm-2.91.91-1.fc15
Policy RPM                    selinux-policy-3.9.15-2.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.38-0.rc6.git6.1.fc15.x86_64 #1 SMP Sat Feb 26
                              01:14:56 UTC 2011 x86_64 x86_64
Alert Count                   1
First Seen                    Sat 05 Mar 2011 09:08:26 AM WIT
Last Seen                     Sat 05 Mar 2011 09:08:26 AM WIT
Local ID                      253ede59-81c8-42a5-95f5-a3b77864b369

Raw Audit Messages
type=AVC msg=audit(1299290906.706:81): avc:  denied  { write } for  pid=508 comm="systemd-readahe" path="/var/lib/gdm/.gconf.mandatory" dev=dm-1 ino=34266 scontext=system_u:system_r:readahead_t:s0 tcontext=system_u:object_r:xdm_var_lib_t:s0 tclass=dir


Hash: systemd-readahe,readahead_t,xdm_var_lib_t,dir,write

audit2allow

#============= readahead_t ==============
#!!!! The source type 'readahead_t' can write to a 'dir' of the following types:
# readahead_var_lib_t, readahead_var_run_t, root_t, device_t, var_run_t, root_t

allow readahead_t xdm_var_lib_t:dir write;

audit2allow -R

#============= readahead_t ==============
#!!!! The source type 'readahead_t' can write to a 'dir' of the following types:
# readahead_var_lib_t, readahead_var_run_t, root_t, device_t, var_run_t, root_t

allow readahead_t xdm_var_lib_t:dir write;
Comment 1 Miroslav Grepl 2011-03-07 05:04:53 EST
*** Bug 682446 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2011-03-07 05:05:16 EST
*** Bug 682448 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2011-03-07 05:17:20 EST
You can try to install the latest F15 policy from koji for now

http://koji.fedoraproject.org/koji/buildinfo?buildID=231903

*** This bug has been marked as a duplicate of bug 669672 ***

Note You need to log in before you can comment on or make changes to this bug.