Bug 682388 - assumes all ethernet devices are named ethX
assumes all ethernet devices are named ethX
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ptlib (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 682389 682334
  Show dependency treegraph
 
Reported: 2011-03-04 21:54 EST by Bill Nottingham
Modified: 2014-03-16 23:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: ptlib-2.8.3-4.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 682389 (view as bug list)
Environment:
Last Closed: 2011-04-26 12:23:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2011-03-04 21:54:19 EST
Description of problem:

Network devices can have arbitrary names, and due to
http://fedoraproject.org/wiki/Features/ConsistentNetworkDeviceNaming, will have
different names in Fedora 15.

In the sockets code:

PBoolean PEthSocket::Connect(const PString & interfaceName)
...
  if (strncmp("eth", interfaceName, 3) == 0)
    medium = Medium802_3;
  else if (strncmp("lo", interfaceName, 2) == 0)
    medium = MediumLoop;
  else if (strncmp("sl", interfaceName, 2) == 0) {
    medium = MediumWan;
    fakeMacHeader = PTrue;
  }
  else if (strncmp("ppp", interfaceName, 3) == 0) {
    medium = MediumWan;
    fakeMacHeader = PTrue;
  }
  else if (strncmp("ippp", interfaceName, 4) == 0) {
    medium = MediumWan;
    ipppInterface = PTrue;
  }
  else {
...

Version-Release number of selected component (if applicable):

ptlib-2.8.3

How reproducible:

By code inspection.
Comment 1 Peter Robinson 2011-03-13 21:49:51 EDT
Reported upstream here: https://sourceforge.net/tracker/?func=detail&aid=3209549&group_id=204472&atid=989748
Comment 2 Fedora Update System 2011-04-20 13:08:37 EDT
ptlib-2.8.3-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ptlib-2.8.3-4.fc15
Comment 3 Fedora Update System 2011-04-20 23:00:42 EDT
Package ptlib-2.8.3-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ptlib-2.8.3-4.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ptlib-2.8.3-4.fc15
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2011-04-26 12:23:05 EDT
ptlib-2.8.3-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.