Bug 682454 - rtorrent fails with: rtorrent: print_status_info(...) wrote past end of the buffer.
Summary: rtorrent fails with: rtorrent: print_status_info(...) wrote past end of the b...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rtorrent
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Conrad Meyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-05 17:08 UTC by David Riches
Modified: 2011-03-11 06:08 UTC (History)
2 users (show)

Fixed In Version: rtorrent-0.8.7-6.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-11 06:08:15 UTC


Attachments (Terms of Use)
patch to fix canvas error (469 bytes, application/octet-stream)
2011-03-05 17:42 UTC, David Riches
no flags Details

Description David Riches 2011-03-05 17:08:12 UTC
Description of problem:

starting rtorrent from the cli results in rtorrent: print_status_info(...) wrote past end of the buffer.


Version-Release number of selected component (if applicable):

2.6.38-0.rc6.git6.1.fc15.i686.PAE
rtorrent-0.8.7-5.fc15.i686


How reproducible:

Every time

Steps to Reproduce:
1. start rtorrent
2.
3.
  
Actual results:

print_status_info(...) wrote past end of the buffer.

Expected results:

rtorrent to start
Additional info:

Nothing in /var/log/messages, no avc's present.

Comment 1 David Riches 2011-03-05 17:42:54 UTC
Created attachment 482461 [details]
patch to fix canvas error

Comment 2 David Riches 2011-03-05 17:43:23 UTC
This patch fixes the issue. I've also got a src.rpm if you are interested..

Comment 3 Ankur Sinha (FranciscoD) 2011-03-05 19:54:19 UTC
Hmm..

Weirdly enough, I haven't been able to reproduce it. Neither have I found a bug on the upstream tracker. I'm filing this upstream. 

I'm on the same version 0.8.7, but on F14.

Reported upstream

http://libtorrent.rakshasa.no/ticket/2518

Thank you for filing the report and providing a patch. We'll probably push an update soon to fix it. 

Ankur

Comment 4 David Riches 2011-03-05 23:33:09 UTC
Thats because the bug occurs with Fedora 15, which uses :

ncurses-5.8-1.fc15.i686

whereas, F14 uses 5.7-9.20100703

The patch fixes the issue for Fedora15's ncurses.

As it stands, rtorrent is broken on F15 and is fixed (fwics) with this patch. I'd imagine it won't be long before this bug gets re-opened by someone else wanting to use rtorrent to be honest.

Comment 5 Conrad Meyer 2011-03-05 23:54:20 UTC
I'm not sure why this was closed -- reopening.

Comment 6 Conrad Meyer 2011-03-06 00:13:29 UTC
Imported the patch to rawhide and kicked off a build: http://koji.fedoraproject.org/koji/taskinfo?taskID=2887948

Unfortunately, I can't seem to figure out how to pull the patch down to F-15 (and build that) right now (and I'm a little spare on time). Ankur, want to do that? Or I can take a stab at it later.

Comment 7 Fedora Update System 2011-03-07 06:01:02 UTC
rtorrent-0.8.7-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rtorrent-0.8.7-6.fc15

Comment 8 Fedora Update System 2011-03-08 02:27:22 UTC
rtorrent-0.8.7-6.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rtorrent'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/rtorrent-0.8.7-6.fc15

Comment 9 Fedora Update System 2011-03-11 06:08:10 UTC
rtorrent-0.8.7-6.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.