Bug 68246 - overlapping window results in excessive screen flashing
Summary: overlapping window results in excessive screen flashing
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xawtv   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-07-08 15:51 UTC by ellson
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-08 18:42:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ellson 2002-07-08 15:51:05 UTC
Description of Problem:
When a window overlaps xatv is moved, the entire screen is refreshed
rather than just the one window.  When a window that doesn't overlap
xawtv is moved only local window refreshing is done as expected.

Hardware is Matrox G450 dual-head.  Window manager is Gnome
(Gnome2 from rawhide).  Focus-follows-mouse.

Version-Release number of selected component (if applicable):
xawtv-3.74-4
XFree86-4.2.0-52
kernel-smp-2.4.18-5.62
gnome-libs-1.4.1.2.90-18
rawhide-release-20020708-1

How Reproducible:
100%

Steps to Reproduce:
1. move window to overlap xawtv's window
2. move window small amount so that it still overlaps xawtv's window
3. 

Actual Results:
Screen refreshes

Expected Results:
Window refresh only

Additional Information:

Comment 1 ellson 2002-07-16 19:02:00 UTC
Problem is fixed by adding
  Load  "v4l"
to the Modules section of /etc/X11/XF86Config-4

Since I created XF86Config-4 manually to deal with my dual-head configuration
I have to assume that this bug is my own fault.


Note You need to log in before you can comment on or make changes to this bug.